Fedora 30 Silverblue: Fatal error during installation

Hi there, I have tried to install Fedora Silverblue 30 to my laptop as a secondary system to Windows 10. However, during the installation, I have got the following error:

ostree [‘admin’,’–sysroot=/mnt/sysimage’,‘deploy’, ‘–os=fedora’,‘fedora:fedora/30/x86_64/silverblue’] exited with code -6

I have tried another image and another USB. Disk partitioning is done by “Custom” and then “create them automatically” link.
I dont know what additional info is necessary to solve it, so tell me and I will post it ASAP.
Could anyone here help me with it? Thanks!

Have a look at this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1575957

Try creating a new EFI partition specific to FSB30 and assign it to /boot/efi

Thank you very much!
Now, everything runs well.

1 Like

Replying here for some visibility…

There’s a new troubleshooting section of the Silverblue docs that covers this issue and others:

https://docs.fedoraproject.org/en-US/fedora-silverblue/troubleshooting/

2 Likes

@miabbott I think I will expand that troubleshooting section. In some cases it is possible to create an additional EFI partition and leave the existing EFI partition untouched, so to avoid making the already installed OS(s) unbootable

That would be great! We need more contributions like that. Thanks in advance!

Bookmarked! I’d like to contribute the solution to a problem I experienced with Toolbox recently, provided nobody beats me to it before I get off work tonight.

1 Like

Keep the contributions coming! :star_struck: :raised_hands::+1:

2 Likes