Cannot install Silverblue 33: grub2-mkconfig error

Hi! I tried installing Fedora Silverblue 33 along with Windows and the installer fails with this error:

error: Bootloader write config: grub2-mkconfig: Child process exited with code 1

rerunning the ostree deploy command I was able to get something more specific:

/usr/sbin/grub2-probe: error: cannot find a device for / (is /dev mounted?).

I reported it at https://github.com/fedora-silverblue/issue-tracker/issues/96 and https://bugzilla.redhat.com/show_bug.cgi?id=1896687 but so far it didn’t get any attention. I was hoping someone here could help with this issue.

This is the first time you mention that this is a dual boot installation. Can you make sure that the installer keeps the Windows EFI partition and creates both a EFI and boot partition for Silverblue?

Grepping for “mount” at the very end of storage.log I’m getting the following output:

1:INFO:program:Running… mount -t btrfs -o subvol=root /dev/sda6 /mnt/sysimage
17:INFO:program:Running… mount -t ext4 -o defaults /dev/sda5 /mnt/sysimage/boot
35:INFO:program:Running… mount -t vfat -o umask=0077,shortname=winnt /dev/sda2 /mnt/sysimage/boot/efi
59:INFO:program:Running… mount -t bind -o bind,defaults /dev /mnt/sysimage/dev
81:INFO:program:Running… mount -t devpts -o gid=5,mode=620 devpts /mnt/sysimage/dev/pts
99:INFO:program:Running… mount -t tmpfs -o defaults tmpfs /mnt/sysimage/dev/shm
119:DEBUG:blivet: BTRFS._pre_setup: type: btrfs ; device: /dev/sda6 ; mountpoint: /home ;
120:INFO:program:Running… mount -t btrfs -o subvol=home /dev/sda6 /mnt/sysimage/home
148:INFO:program:Running… mount -t proc -o defaults proc /mnt/sysimage/proc
178:INFO:program:Running… mount -t bind -o bind,defaults /run /mnt/sysimage/run
206:INFO:program:Running… mount -t sysfs -o defaults sysfs /mnt/sysimage/sys
234:INFO:program:Running… mount -t efivarfs -o defaults efivarfs /mnt/sysimage/sys/firmware/efi/efivars
262:INFO:program:Running… mount -t selinuxfs -o defaults selinuxfs /mnt/sysimage/sys/fs/selinux
266:INFO:program:Running… mount --rbind /mnt/sysimage /mnt/sysroot

so I guess sda2 is the EFI partition and sda5 is the boot partition.

I don’t know if this is your issue but the following links might help:

Edit: If sda2 is Windows EFI partition then you have to do a custom install to make sure Silverblue gets its own EFI partition until this is fixed.