Cannot install Silverblue 30: "failed to write boot loader configuration"

Hi all,
I am new to Fedora, or at least would like to be but I cannot get Silverblue to install onto my laptop!

  1. In the installer I choose the advanced custom partitioner to retain Windows. I create btrfs subvolumes for / and /home, I assign it an exclusive EFI partition. I try to avoid any future break points and to please the partitioner by omitting encryption and creating separate /boot (ext4) (why is that even necessary?).

  2. the installer proceeds right to the end where a popup complains:
    failed to write boot loader configuration

  3. Before closing the popup window I switch to console with ctrl-alt-F2. Because the destination filesystem is still mounted:

    # chroot /mnt/sysimage/fedora/ostree/deploy/......123.0
    I notice that
    /etc/grub2-efi.cfg -> ../boot/efi/EFI/fedora/grub.cfg
    which is nonexistent (/boot/efi is mounted) and
    /etc/grub2.cfg -> ../boot/grub2/grub.cfg
    also nonexistent.

    As instructed in fedoraproject.org/wiki/GRUB_2 I run
    # grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
    only to get this error:
    /usr/sbin/grub2-probe: error: cannot find a device for / (is /dev mounted?).

    yes, /dev is mounted because it is populated with my /dev/sdaX and /dev/nvme0n1pX devices

How can I fix this please?


edit:
added https://bugzilla.redhat.com/show_bug.cgi?id=1741060

Last time I tried, the Silverblue installer didn’t work with btrfs, most likely this is that same issue.

I guess I have to learn more about ostree - I thought it would use btrfs snapshots when available!

In any way I don’t see a bug report and this seems like a very basic feature…

Silverblue doesn’t need to use btrfs for rollbacks, it has ostree for that…

But otherwise, yes it’s a known bug. It’s possible it might work with btrfs for /home, but I haven’t tested it.

I will try it with ext4 then.
How do you think I should split the space between / and /home when I have 100GB of space?
…this sounds a lot more like 2009

This is likely the same issue as reported here https://bugzilla.redhat.com/show_bug.cgi?id=1289752

There are some suggestions to try in the comments there, but overall it looks like btrfs is not working.

If space is a concern, you can forgo the separate /home partition.

It probably isn’t a concern so far but it’s exactly what I did in the end anyway.

So installing onto luks/ext4 works just fine by the way! Now, how to get rid of the pesky unencrypted /boot partition?
I tried moving its content to /boot dir on the root partition, commenting out the entry in /etc/fstab and running the grub2-mkconfig - it still does boot but only until I delete contets of the original boot partition
: )

A bug from 2015! Thank you for the link - it does seem to be a problem with grub2, ie. grub2-probe triggered by grub2-mkconfig, not just the installer then, or is it not?