[Solved] F40 KDE Panel auto-hide not hiding

Just updated to latest bits on my Dell XPS 9520 laptop & the KDE panel is no longer auto-hiding.

I tried changing the mode to always visible then back to auto-hide but no hiding behavior is manifested - panel is visible all of the time.

Edit: Hmm, just noticed this window is now behind the panel so it seems that the setting is “Windows go below” even though I hadn’t selected it. It seems that nothing I do puts it into auto-hide mode.

Behavior was correct before updating to latest bits as of a few minutes ago.

If I can jam 2 issues into one post (probably not) - since F40 I’ve noticed that my keyboard light setting isn’t maintained across boots, or even sleeps - I have to keep setting it with the fn+F5 key (on this particular laptop, obviously).

Yeah, you should have one topic per thread. It avoids confusion that way.
Open a second thread for the keyboard light.

OK, thanks.

Very weird: I just added a keyboard shortcut using System Settings, didn’t change anything else in the system, and suddenly my panel is auto-hiding again!

I guess this is “solved” but why it suddenly started working when changing the setting to the various options resulting in no behavioral change is completely unknown.

I believe I did update to a few more recent binaries after the original post was submitted, but the incorrect behavior continued after the update.

Presumably something in System Settings → Apply went through and updated settings other than the keyboard shortcut that I was specifically adding.

I wonder if my keyboard backlight issue is now similarly “fixed”?