Screen keeps locking up

Hello, First post here.
I’m using Fedora34 Xfce with Openbox. Been using the same since 2014, more or less.
now (starting today), every couple of minutes my screen goes off and locks down, which is driving me crazy.
I have to say installing F34 has been a mistake. It keeps malfunctioning, nothing runs properly, and now, this. I should’ve stayed with F30.
In any case, I keep going to the xfce4-settings-manager (which has done the trick beautifully before) and all the power settings seem to be in order, but the screen keeps getting locked.
What am I missing?
Thanks in advance. :slightly_smiling_face:

I am using gnome not xfce, but there is a settings panel where I set the screen lock time out.
settings —> privacy —> screen lock.
Is your settings manager similar?

Yeah, I guess so. but Openbox seems not to be responding to it… :man_shrugging:

You might try disabling the screen lock in the VM so it never blanks/locks. I would assume the host will lock its screen appropriately so why need the VM to lock the screen.

If it didn’t happen before, can you think of what changed to cause it—were some packages updated, for example?

Edit: there have been no changes to xfce4-power-manger in F34 recently, so shouldn’t be that:

Could you check your journal logs to see what they say around the time the screen goes off too please?

Thank you all for the replies.
Sorry, I should’ve added more information.
I installed F34 a few days ago. it was definitely quirky, but I could live with it. I did the install as I always do: Installed F34 Xfce normally through wi-fi (I don’t have ethernet access, so I can’t netinstall), and then added Openbox, xbacklight, feh, conky, tint2, network-manager-applet, libreoffice, bluefish, gcolor2, gimp, scrot, xsane, glabels, beesu, compton, terminator, idle, vlc, gedit, filezilla, nitrogen, simple screen recorder and visual studio code.
Most everything worked properly, with the exception of vlc, that keeps loosing sound intermittently (I’m using Parole media player instead) and the issue with the screen timeout, which only happened with vlc and parole.
Now, since I did the last update, I’m learning web development in, watching an embeded video on the page, and everything locks down, but the audio keeps playing. :man_shrugging:
In past fedora versions (I started using it on F27, all installed identically), it took me 2 or 3 tries on the xfce-settings-manager for the screen timeout to finally be disabled. on F34, I thought that was it, as I didn’t have any problems, except the ones mentioned above, but screen keeps locking up.
I went to xfce-settings-manager several times. Everything seems to be in order. Now I ran journalctl on the terminal, but the log is over 140 000 lines long, and I don’t have a clue what I’m looking at, and for some reason there’s not a single line on September 16. Nothing. In fact, there’s not a single line between September 3rd and today, even when I use my computer daily.
So I’m at a loss. I’m not an expert, just a normal end user. I’m planning on following a linux administration course after I finish this one, but, so far, I really have no clue.