RStudio missing Quarto in Fedora RPM

Hello everyone,

I’m relatively new to Fedora, have been using it for a few months now, currently on F37. I installed RStudio using the software application from the fedoraproject RPM. Unfortunately, it is missing the option to open or create Quarto documents (a scientific publishing system based on markdown - creating documents should be possible through File > New File > Quarto Document).

The version seems to be the most recent one (2022.12.0+353) compared with the official download page. When I download and install the version from the Posit download page (exactly same version number), the option exists and I can work with Quarto documents normally.

So this could be the solution to my problem, but weirdly, a few days after installing the RPM from Posit, all shortcuts to start the software (from dash, search, app grid) vanish without me doing anything (at least anything I’m aware of). This has never happened with any other software before.

At first I thought the software had miraculously uninstalled, but dnf list installed still shows rstudio.x86_64 2022.12.0+353-1.fc37

So my questions are:

  1. Why is the RStudio version in the Fedora repository different from the “official” one despite having exactly the same version number?
  2. Any idea why all the application icons disappear?
  3. How to make them reappear (reinstalling the software works, but this is not a viable solution considering that I’d have to do it every few days)? And at the least (probably a beginner’s question): How do I start RStudio without having an app icon to click on? Simply typing rstudio in the terminal offers me to install the rstudio-desktop package which I don’t want because [see above :wink:].

The problem with Quarto missing has been mentioned in the RStudio Community but without a solution. I tried installing Quarto manually which was successfull (tried /usr/local/bin/quarto check) but didn’t change anything about RStudio integration.

I’d be happy about any advice or idea you might come up with. Thanks in advance!

Kind regards

1 Like

The best place to file this is in Bugzilla, but as a temporary workaround in the meantime, I maintain some Rstudio container images at work that include Quarto:

Some of the course images, that are also public, include more tex libraries, etc, that you may or may not need, or you can easily make your own downstream image from it.

Thanks for your help Scott, I really appreciate it! I’ll have a look at your images.
For reference: bug report has been filed (2162538 – RStudio package missing Quarto despite being most recent version)

Kind regards,

1 Like

Same problem. I have just followed the following links on action to deal with it from here:

I’m not a developer and may have misunderstood.

My understanding is that:

  1. Fedora disables quarto in its package for R Studio and cannot change that (because too hard to deal with Dart SAAS and Dino)

  2. rstudio started fixing it by searching for a user installed Quarto when the Quarto it normally bundles is not there.

  3. But this has been moved to a low priority backlog-2 list that is 6% complete with 192 open issues and 13 closed.

  4. Possibly the issue will remain unfixed because of misunderstanding on June 8 that was not corrected following an explanation on June 14:

  1. I am not competent to clear that up.

  2. Hopefully there is a simple work around.

  3. I was able to install Quarto to ~/.quarto instead of /opt by modifying the instructions at:

  1. Also ran successful check and produced html and docx output including plot that used jupyter, matplotlib and plotly using gedit to write the hello.qmd file here:
  1. Rendering to pdf failed with existing Fedora TeX installation so I (later) also installed TinyTeX, which worked.

  2. I only need R Studio for the Quarto Visual Editor, which depends on knitr and Rmarkdown and could also have provided the TinyTeX which I ended up installing from Quarto.

  3. Just typing rstudio offered to install rstudio-desktop which I accepted.

The following packages have to be installed:
clang-16.0.5-1.fc38.x86_64 A C language family front-end for LLVM
clang-devel-16.0.5-1.fc38.x86_64 Development header files for clang
clang-tools-extra-16.0.5-1.fc38.x86_64 Extra tools for clang
glyphography-newscycle-fonts-0.5.2-10.fc38.noarch A realist sans-serif font family based on News Gothic
llvm-16.0.5-1.fc38.x86_64 The Low Level Virtual Machine
rstudio-2023.06.0+421-1.fc38.x86_64 RStudio base package
rstudio-desktop-2023.06.0+421-1.fc38.x86_64 Integrated development environment for the R programming language
soci-4.0.3-3.fc38.x86_64 The database access library for C++ programmers
soci-postgresql-4.0.3-3.fc38.x86_64 PostGreSQL back-end for soci
soci-sqlite3-4.0.3-3.fc38.x86_64 SQLite3 back-end for soci
yaml-cpp-0.7.0-3.fc38.x86_64 A YAML parser and emitter for C++
Proceed with changes? [N/y] y

  1. So it proceeded with log to ‘/home/admin/.local/share/rstudio/log/rdesktop.log’

warnings about /usr/include/R missing.

  1. Within RStudio I used the Tools/Install packages… menu to produce .Rhistory:


  1. I kept the terminal logs which I don’t understand except that this theme seemed quite salient in all four failures:

Warning: R include directory is empty – perhaps need to install R-devel.rpm or similar

dnf list R-devel

Available Packages
R-devel.i686 4.3.1-1.fc38 updates
R-devel.x86_64 4.3.1-1.fc38 updates

  1. So I found my way to:

which I don’t really understand well enough to be confident about what to do next.

  1. My first guess is:

dnf install R-devel.x86_64

then try again to install knitr and rmarkdown within Rstudio.

But I expect that not to work since still need Fedora RStudio to know about Quarto

  1. My second guess is

Download Fedora 36 version despite being on Fedora 38 from:

The downloaded file is 208.6 MB and not .rpm


Extracting its contents does not immediately show me a file that tells me what to do with it and whether I need an R-devel.rpm or where to get one.

Hopefully that was built by them and bundles Quattro while also fitting in to the rest of Fedora 38 despite being built for Fedora 36?

There are several hundred source repositories at:

dnf remove rstudio-desktop {unsure what to do about any debris left over}

  1. Third guess is follow up on suggestion to use:

But that looks intimidating too.

  1. Please provide a short simple instruction for non developer end user to install Posit version of R Studio with working Quarto Visual Editor on Fedora 38.

  2. My draft is:

mv rstudio-2023.06.1-524-x86_64-fedora/rstudio-2023.06.1-524-x86_64 ~/.rstudio
ln -s ~/.rstudio/rstudio ~/.local/bin/rstudio


sudo dnf remove rstudio-desktop
rm -r ~/.quarto

Then figure out how to make a desktop icon and hope it all just works.

Please advise.