Missing application in F31 repos

I have been using gEDA on Fedora for years; it’s a tool for designing electronic circuitry. I recently did a clean bare metal install of F31 on the machine I use for such purposes. After the install I ran my script that installs the applications I use and left the machine to sit over the holidays. Today I went to work on a design and when I tried to open the file, I discovered that gEDA had not been installed. On further checking I see that gEDA is not in the F31 repos. I checked the gEDA project website and I see it is still there and being maintained. I’ve got a couple hundred hours of work to redo with a different tool if gEDA is no longer going to be on Fedora. This doesn’t count the symbols I’ll have to recreate. I’m really curious as to why gEDA is not in the repos.

was reported in bugzilla:

1772164 – geda not longer available for fedora :fedora: 31
1740398 – None of the geda tools can be installed in fedora 30 :fedora: 30

you can try to download the SUSE packaged and install it via dnf… from here:


or installl it via source:


or better approach download from here:


NOTE: maybe an orphaned package or lack of maintainers:


Thanks for the suggestions, unfortunately, for verious reasons none of them worked out. Yes Fedora Orphaned and Retired gEDA. Now that I have had more time to think it over, I’m better off going with a new tool than trying to keep the old one going. Though the files are useless, I do have paper copies of all my designs. I’ll just have to get copies made and store them. This has happened before even when I was on that other OS and paid dearly for the design software. Back then though they usually provided file translators or something to make the change less painfull. There has never been anything like an open file format for circuit design schematic files. If a design was all digital things like VHDL helped. I guess I have to start looking at Fedora Planet more often to look for lists of things about to be retired.

Are the lists of Orphaned and Retired packages posted at specific times? Is there a specific interval between Orphaned status and Retired status?

Thanks again for your help.

If gEDA is The tool, you may just run a distro that has the latest gEDA in their repository or for which a compiled package is available downlaod, see geda:download [gEDA Project Wiki]

Or you could simply run a virtual machine with Debian or OpenSuse to power gEDA. (for example: https://ubuntu.pkgs.org/19.10/ubuntu-universe-amd64/geda_1.8.2-11_all.deb.html)

Thanks for the VM suggestions. I appreciate it. I reviewed my current project and custom devices in the library. My more rational estimate of time to get back to where I was is about sixty hours. I’ve also done some reading on Kicad which is the current offering in the Fedora repos. Kicad seems to have a lot of fans and is seems to be producing good results. Also, they have a number of sponsors like companies and universities. I think that will help them live long and prosper. Given that I’ve decided to go ahead and move to Kicad. I’m also guessing with their sponsored situation will make it more likely that when Kicad is replaced someday that a file translator will be provided to help people migrate to whatever comes next.

Again, thanks for the suggestions and Have a Great Day!

great election: