FreeCad on Fedora31

FreeCad installs fine, starts fine, looks good. Then I try to load an example or one of my own designs and it crashes. I have installed from the Software app and the command line; no difference. Won’t load a file and stay open.

In meantime your can try this:

FreeCad: downloads (has Linux AppImage).

1 Like

Did you start it from a terminal to find out what kind of messages it gives? Maybe it is a local problem that you can solve. If not, it might be worth a bug registration at redhat’s bug. Even if it is not a bug, the people supporting bugzilla’s are usually knowledgeable.


Yes, let us try to see why the Fedora packages are not working before we suggest direct downloads/AppImages/whatever. Please remember that for direct downloads, the community cannot help—they do not go through our packaging and quality assurance systems. Only if the Fedora packages are completely broken (or something isn’t packaged at all), should direct downloads and so on be suggested.

1 Like

The best option so far, avoid the use of the package from fedora it is mainly break because the maintainer who also has a account here do that he want. He build the package in others versions of fedora and doesnt check if it does work in the actual version. And another things, this guy gave us alot of work …

And the people need do their work and not wait weeks for another breaks. This package freecad is going break every time . Use appimage works always. FEM soft is built in and don’t fail. Library of material does works too… Really dont use fedora package use Appimage if you need work and avoid problems created for others.

Always that you can go to a direct package. Appimage, flatpak ,avoid distro packages… I told you for experience, I needed worked and not solving problems that others do create for his bad understanding of that it should be.

Time ago was another guy who need use scilab but if you need scilab to work and stability and it is not happening in some packages of fedora or any other distro. It is just my experience and maybe the others too.

I am tired of politic stuff around don’t recomend the other option (what is always direct and stable) in place of stay here and report the bug fot the good of all , i understand this part but the people need work and be sure that the program not will do error more if you are calculeting structures or doing FEM etc… like scilab, freecad.

Sorry for my bad forms but it did my get bad.

Have en good day.

1 Like

The bug that you have linked to shows that Richard has been working continuously to fix the package. It is not a simple package, and given the dependencies that it relies on also need to be kept in sync, it is an even harder job. I do not see any politics there. It is just a complex package to maintain.

People do need to do their work, and this also applies to package maintainers. They are volunteers, they do this in their free time—by squeezing out hours after their dayjobs and their personal lives. I do understand that it is frustrating when things break, and sure, for a workaround, feel free to use whatever works. However, such remarks are not in the “be excellent to each other” category. We are all part of the community, and we must work together to improve things. Negative comments about volunteers does not do that.

First, please re-read the code of conduct.
Next, please consider spending some time to understand the requirements of maintaining complex packages,
Finally, please consider helping the maintainers by joining up to maintain packages that you rely on.


Every point i understand, but there looks like we forget to provide the user the right way to do his experience a bit more easy. If there out is a package that is provied for freecad does work good and in the other hand in the repo is there a package with problems very often, we can not recomend use it, because it is not honest to the user who only wish work and avoid waste alot of time with problems. Everyone try help here it can be seen in every post from users. But sometimes to stay close to some decisions in not the best way imho, is going to show a not easy way to the users. Richard is working in it, but he was packaging the freecad version to fedora 31 in fedora 30 depences was broken logically… Respect to all volunters like everyone that do take his time here to help others. But if there are bad things that happen is important to say too. And it is that i think. Don’t worry about me it will be my last post here, I don’t want blame more about things that dont need, Fedora is an awesome distribution maybe the best, but like an user and in this case if a package is breaking so often best give a step back and wait until it is stable. But well it is my opinion.

I did help in the best way that i could and always thinking in the user not in fedora not in another thing, And i am sorry i will always be honest with my self and that i think and about code of conduct you will have not problem with me again.

Thanks you all that do posible fedora. !!

1 Like

I’m in the process of backuping my /home dir. I’ll dualboot with Fedora and an “gaming” distro. I’ll check out GNU / Guix. I’ll see their package system, as i’d never tried this one before. But they’re don’t support the LVM.

Why i’d posted this: Thier manual says something about… err… an another variant of conteiners. Didn’t get it in my head yet.

Yes, I was looking for GNU/Guix too yesterday in the night hahaha…. Crazy to me to see you talk about the same thing. I will try some day if i find the time and the energy :smiley:


Skickades från E-post för Windows 10

Sure, I totally understand your views, and I empathise with your frustrations. I’ve seen breakages too, and it does sometimes affect work and so on also.

Thanks for pointing out the issue—that certainly is important. It’s just that it needs to be done the right way while always being excellent to each other :slight_smile:

1 Like

Thank you for understand my point.


1 Like


I was unable to reproduce this issue. My instance of FreeCAD opened a random .FCstd file without crashing. Perhaps its because I am running it in Rawhide but someone else should try to replicate the issue in F31. The only issue I see here is that it throws an error when one tries to change Module/Workbench.

'Shiboken.ObjectType' object is not iterable
Traceback (most recent call last):
  File "<string>", line 32, in Initialize
  File "/usr/lib64/freecad/Mod/Draft/", line 44, in <module>
    from DraftGui import todo, translate, utf8_decode
  File "/usr/lib64/freecad/Mod/Draft/", line 274, in <module>
    class DraftBaseWidget(QtGui.QWidget):

That may need a separate thread or bug report. I have FreeCAD 0.18 here …

Could you pass the file you are working on, if that’s okay with you?


Here is what I got running FreeCAD 0.18 from the CLI. HP Pavilion, i7, 16 GB ram, Fedora 31. Most everything is from the fedora repos.
FreeCAD loaded normally to the start page. Crashes when I try to open any file to edit it.

[tom.price417@localhost ~]$ FreeCAD
FreeCAD 0.18, Libs: 0.18RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019

#### ###

# # # #

## #### #### # # # #

# # # # # # # ##### #

# #### #### # # # #

# # # # # # # # ## ##

# #### #### ### # # #### ## ##

I am using freeCAD on F31, fully upgraded, installed from fedora repo using dnf.

Some little time back on F31 I had an episode where an updated version would not run, and repeatedly crashed where an earlier version had been working perfectly.
I downloaded the appimaage and it worked perfectly, so I kept digging as to the cause.

What I found was that the updated freeCAD required 2 additional python packages that were not previously installed, and that the freeCAD update had not installed as required dependencies.

At one point I was able to identify so I could install the needed packages, but before I did that
I finally got the version from the repo to work by doing a “dnf erase freecad --noautoremove” (to avoid erasing and reinstalling a lot of dependencies) followed by a “dnf install freecad”. That process then called out the missing dependencies and installed them for me.

FreeCAD works fine for me now without using the appimage.