Error while trying to upgrade from 38 to 39: it seems to be a problem with freecad

While trying to upgrade to Fedora 39 from Terminal I’ve got this error message:

Problema: package freecad-data-1:0.20.2-3.fc38.noarch from @System requires freecad = 1:0.20.2-3.fc38, but none of the providers can be installed

  • freecad-1:0.20.2-3.fc38.x86_64 from @System does not belong to a distupgrade repository
  • problem with installed package freecad-data-1:0.20.2-3.fc38.noarch

Does it means there isn’t Freecad available on Fedora 39?
I’ve also tried with :
sudo dnf system-upgrade download --releasever=39 --skip-broken

Nothing change, same error.
I may dis-install Freecad and try to upgrade, I just worry if I won’t be able to install it again after upgrade.
Any suggestion?

If you look at Overview - rpms/freecad -, you can see there is no F39 build. The dead.package file in git has this to say:

Fails to install with Python 3.12
See 2219998 – F39FailsToInstall: freecad
Retired via Issue #3080: Retiring 5 packages without a Python 3.12 rebuild from Fedora 39+40 - fesco -

So, yes, it is not available for Fedora 39.

1 Like

I see, thank you.
I may be able to install it as flatpak, I just saw it’s available from Flathub, right?

1 Like

I see it on Flathub too, yes. Hopefully that version will work for you.

1 Like

I had the same issue and installing freeCAD as a flatpak worked in F39 for me.

Hopefully freeCAD will be updated quickly to work with python 3.12.

1 Like

It looks like a PR was very recently merged upstream to get FreeCAD to not depend on distutils that had been removed in 3.12:

That means there is yet hope for it in 39!

1 Like