Recent Fedora 33 install now broken - not disk access

While on a phone call, my running Fedora OS appears to have committed suicide. It shut down, and when I tried to wake it from sleep it was a not-go. Trying a fresh boot, there was a stall at the Fedora screen that was far too long (2-3 minutes?) followed by this:

I followed the instructions and read through about 9 pages of system log, of which I could only make a little sense, but I did get photos of every page. What seemed to be the problem was that some drive was missing. As it turned out that missing drive was my SSD containing the boot, root, and home partitions, among other things.

As I need quickly to get use of my computer back, I decided not to post the problem here but to just reinstall Fedora.

I should mention that yesterday I turn my laptop into a dual boot machine by installing Xubuntu on a couple of partitions created out of space obtained by shrinking my /home partition. It loaded just fine once installed, and so did my Fedora…until this incident today.

When I tried to reinstall Fedora and go to the point where one is given options for setting up the partition(s) for the install (the “Installation Destination” screen), I was unable to request a “custom” storage configuration, and then saw at the bottom of the screen an alert message: “No disks detected…”, followed by a request that I shut down the computer and attach a storage disk!

I was disbelieving. I reran the Fedora install attempt, and from the Live disk fired up KDE Partition Manager and it too did not see my laptop’s only storage drive, a 512GB SSD.

Here is my full system configuration:
Acer Spin 5 / 15.4GB RAM / 512GB SSD
Operating System: Fedora 33 (Linux) / KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.75.0 / Qt Version: 5.15.2
Kernel Version: 5.9.11-200.fc33.x86_64
Processors: 8 × Intel® Core™ i7-1065G7 CPU @ 1.30GHz
Graphics Processor: Mesa Intel® Iris® Plus Graphics

I have never seen this problem before and have absolutely no idea what to do about it.

I will be grateful for any suggestions!

The only thing you can do is to completely wipe out all your storage devices and reinstall all your OS’s , one after one. Have you encrypted anything?

Before you dig any deeper and try to reinstall you need to find out why it sees no disks.

Have you tried booting back into windows.?
You said that is a laptop and if both fedora and windows have lost the drive then that seems a mechanical (hardware) problem and not directly related to the OS.

1 Like

How do I do that if the drive has suddenly become invisible? Any program that does would need to address the drive and it appears to have vanished. (See below for more on this.)

No - there is no encryption on the drive.

I installed Fedora over windows - it’s gone.

I am actively considering that there may be some hardware issue. I will be contacting Acer about this.

My thanks to both of you for your suggestions!

Does your drive show up in bios?
If so and data does not matter I would secure erase ssd from bios if your has that option.
I have found that different distros have varying success recognizing drives in weird cases.
If another live cd can see the drive use of a command like
dd if=zero of=/dev/sda status=progress could than be used to clear any offending data of set drive. hdparm secure erase also becomes an option. hdparm secure erase was what I found worked for this same issue I had with a 4tb hdd. It took forever but it was still much quicker than having a new drive shipped. Arch wiki has good instructions for the hdparm procedure.

Good Luck the drive may still be there in all reality.

Also, on a live cd, open a terminal and run lsblk. Do you see there your ssd? If so, run the opposite command youtubezombie mentioned, ‘dd if=/dev/sdX of=/dev/null status=progress’ and check if it will read the correct ssd size.