Fedora 34 Installer Not Detecting Local HDD | Intel Optane 16GB

Hi, everyone… I’m hoping you can help me. I’ve been trying for a few hours now to install Fedora 34 on my Acer Aspire 5, but everything I’ve tried doesn’t seem to be working. I have SATA in ACHI, it’s in Legacy Boot mode, everything that the help videos online said to disable is disabled… but for some reason the installer still cannot detect my local hard drive… I’ve tried adding a new partition, but to no avail. As far as I understand my BIOS, the computer is detecting both HDD0 & HDD1. The only thing I can see that is different from the videos is the Security tab has a lot more info listed. There are no passwords on the drives as far as I can tell. I cleared the only one that was there, but still the installer cannot detect my local hard drive. I’m trying to save my laptop because Windows 10 updates were starting to cause hardware incompatibilities. Please help… I really can’t afford to replace my laptop… Plus, it’s not even 3 years old, so I’m kind of mad that Windows is already causing it to malfunction. I know it’s Windows because the problem doesn’t appear at all when booting up using my Fedora 34 USB booter. If you need pictures of my BIOS screens, I can add them. I hope you guys can help me… Thanks for your time~

1 Like

Here is the Security Tab…

When I restarted my laptop in order to access BIOS to take this picture and others… I noticed that several of the settings had been changed from what I had entered the last time AND that the security password on one of the HDD had returned, despite the fact that I had cleared it… so now I’m pretty well convinced it’s the security settings that are the issue… I did some more research & believe I’m dealing with a locked drive. Am I correct? Should I try formatting the drive?

During the installation attempt what happened?

When you boot the usb device to start the install you should click the “try fedora” icon, then from the live os open a terminal window .
Use “su” to become root then run “fdisk -l” and post the output here.

If fedora can see the device then we can proceed. If fedora cannot see the device then it seems a bios issue and some settings may need tweaked.

Just as an aside, I much prefer UEFI boot, and unless you are keeping windows and it is already installed in legacy mode there is no reason not to use UEFI boot.

2 Likes

Thank you for your reply… I’m pretty sure the security settings on the drive were making it impossible for the Fedora 34 installer to detect the drive. I did more research and found a way to remove the security, then rebooted the laptop using my Fedora USB booter. It still couldn’t detect the drive… BUT!! I found a way to format the drive through Fedora, which will erase Windows entirely & prep the drive for Linux! I had already backed up all my data and erased the drive twice, so there was nothing on it but Windows. The formatting will take up to half a day, so it’s a waiting game at this point. However, I really think this may solve my issue as formatting the drive will completely erase all the Windows programming & secuirty that was on it~ :slight_smile:

I’ll post an update later to let everyone know! If this works, I’ll also post my step-by-step process on how I got around the security and fixed everything. :wink:

1 Like

Good idea:
It would have been faster to install gparted into the live OS you have running and just create a new partition table, then do the install. (Or use gdisk to do the same.) It would format and overwrite everything already on the drive that way.

1 Like

Ok… The format didn’t work… But maybe it’s because I only formatted the main partition and not the whole drive? When I click on Disks it shows me all the drives on the computer, including the original partitions that Acer & Windows had on it. However, it also shows me that all of them are “Not Mounted”. I’m pretty sure this is the reason Fedora is unable to detect them. When I click on the settings for each partition it shows me that they are set to mount upon startup… so it doesn’t make sense that they are not mounted. After formatting the main partition I am able to now manually mount the drive, but the installer still cannot detect it and even after I’ve manually mounted it? Disks shows that it’s “not mounted”… I’m thinking I should format all the partitions- The security may still be active on one of the other partitions.

gparted, huh? I’ll give it a try.

Ok… downloaded GParted… and it won’t run. I just see files for the program…

I’ve now formatted all the partitions and combined them into one single partition. I have it mounted & Disks shows me it’s mounted… yet the installer still cannot detect the drive. I’m gonna try the first thing you said.

There’s two other drives named “Anaconda”… I’ve no idea what they are or what they are doing. but they are listed as “/dev/dm-1” & “/dev/loop1”… Then there’s a third drive volume with no name listed as “/dev/loop0”… Could they be the issue?

Ok… Just noticed something strange… When I click on Fedora’s “Install to Hard Drive” program? The main drive I wish to install it on unmounts itself & one of the Anaconda drives disappears… the one labelled “/dev/dm-1” I remounted the drive I wish to install Fedora on, but the installer still cannot detect it. This is so strange…

I’m gonna try a UEFI boot and see what happens.

Remember one thing.
The installer CANNOT do the install to a mounted drive. When you boot to the live USB device and start the installer the only drive that should have partitions mounted is the USB. The HDD or SSD should be sitting idle waiting for the install to begin. The OS will not be able to see the device as a mounted file system, but only as a device visible in /dev that is currently unused. I have thought that your comment that fedora could not see the drive meant that it was not visible at all, meaning it was not seen in /dev. Instead you seem to not see it as mounted which is normal for installation time.

Also, the installer will need to have space for the install, so since you are doing the install as if it were a new machine then simply tell it to use the entire drive and do an automatic partitioning install and it should work.

1 Like

Ok… I’ve tried everything I can think of… The drive is detected in Disks, but still not detected by the installer. I’ve taken the laptop apart a second time to disable the security because it re-enabled itself after I shut down the device, yet still nothing. The drive is wiped, formatted, & unmounted… I have all the BIOS settings set as instructed, but still nothing. I tried booting both in Legacy & in UEFI… booting in UEFI re-enabled the security. Is there something I can do in DIsks? Or maybe there’s something wrong with my Fedora Installer? I’m figuring this out as I go, so I’m not sure what else I’m missing. Thank you for your help~ I’m extremely glad I got this far! My hardware is no longer malfunctioning at least and I can do some things I used to always do. I just can’t save anything on my laptop until I get the new OS installed… Which is a bit of a pain since that means I can’t use it for my work like I used to.

I’m gonna try making a DVD for installing the OS… I just have to go purchase a blank disc to do so. Maybe that will work.

To attract the audience with same hardware issues put brand and model name in title.

Try to install:

In terminal: sudo dnf install inxi
afterwards type in terminal: inxi -Fzx
And post the output here as preformated text pls.

It looks like that the NVMe drive is one of them who not get detected from anaconda.
If we do have more info we can help to search for solutions.

1 Like

I honestly have no clue how to post the output as preformated text… I’m sorry… I can post a print of my screen though~

If I’m understanding what I’m reading… There’s an error in my installer? It says, “Failed to download metadata for repo”…

Also, how do I edit the title of this post to include my computer model? This is all a first for me, so I’m a bit of a noob. Last time I switched to Fedora was a decade ago & I was able to do so with a boot disc. I’m a bit behind in my tech knowledge… :sweat_smile:

Trying to burn a boot disc failed… :sweat:

I have my tablet that’s limping along with half its hardware malfunctioning due to Windows also… I’m going to use it to redo my Fedora USB booter. Maybe that will help fix the issue.

OK! Well… after redoing the installer it still cannot detect my local HDD. However, it did change what happened when I followed your instructions this second time. It did a bunch of updates and installed new software. Then the readout I got when I put in the 2nd command was completely different. I’ll share what I got here… I finally figured out how to copy/paste from Terminal~ :sweat_smile: :blush:

[liveuser@localhost-live ~]$ sudo dnf install inxi

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.
Fedora 34 openh264 (From Cisco) - x86_64        1.3 kB/s | 2.5 kB     00:01    
Fedora Modular 34 - x86_64                      4.3 MB/s | 4.9 MB     00:01    
Fedora Modular 34 - x86_64 - Updates            1.2 MB/s | 4.6 MB     00:03    
Fedora 34 - x86_64 - Updates                    8.6 MB/s |  22 MB     00:02    
Fedora 34 - x86_64                               11 MB/s |  74 MB     00:06    
Dependencies resolved.
================================================================================
 Package                    Arch      Version                  Repository  Size
================================================================================
Installing:
 inxi                       noarch    3.3.06-1.fc34            updates    392 k
Installing dependencies:
 freeipmi                   x86_64    1.6.8-1.fc34             updates    2.0 M
 hddtemp                    x86_64    0.3-0.47.beta15.fc34     fedora      58 k
 ipmitool                   x86_64    1.8.18-21.fc34           fedora     390 k
 lm_sensors                 x86_64    3.6.0-8.fc34             fedora     135 k
 lm_sensors-libs            x86_64    3.6.0-8.fc34             fedora      41 k
 perl-Compress-Raw-Bzip2    x86_64    2.101-3.fc34             fedora      34 k
 perl-Compress-Raw-Zlib     x86_64    2.101-3.fc34             fedora      61 k
 perl-Cpanel-JSON-XS        x86_64    4.25-2.fc34              fedora     152 k
 perl-JSON-XS               x86_64    1:4.03-3.fc34            fedora     110 k
 perl-Math-Complex          noarch    1.59-477.fc34            updates     57 k
 perl-Types-Serialiser      noarch    1.01-2.fc34              fedora      20 k
 perl-XML-Dumper            noarch    0.81-39.fc34             fedora      26 k
 perl-XML-Parser            x86_64    2.46-7.fc34              fedora     233 k
 perl-common-sense          x86_64    3.7.5-5.fc34             fedora      32 k
 wmctrl                     x86_64    1.07-30.fc34             fedora      35 k
 xrandr                     x86_64    1.5.1-2.fc34             fedora      45 k
Installing weak dependencies:
 perl-IO-Compress           noarch    2.102-2.fc34             fedora     256 k
 perl-Math-BigInt           noarch    1:1.9998.18-458.fc34     fedora     190 k

Transaction Summary
================================================================================
Install  19 Packages

Total download size: 4.2 M
Installed size: 16 M
Is this ok [y/N]: y
Downloading Packages:
(1/19): perl-Math-Complex-1.59-477.fc34.noarch. 406 kB/s |  57 kB     00:00    
(2/19): inxi-3.3.06-1.fc34.noarch.rpm           1.7 MB/s | 392 kB     00:00    
(3/19): hddtemp-0.3-0.47.beta15.fc34.x86_64.rpm 320 kB/s |  58 kB     00:00    
(4/19): freeipmi-1.6.8-1.fc34.x86_64.rpm        4.8 MB/s | 2.0 MB     00:00    
(5/19): lm_sensors-3.6.0-8.fc34.x86_64.rpm      815 kB/s | 135 kB     00:00    
(6/19): ipmitool-1.8.18-21.fc34.x86_64.rpm      1.4 MB/s | 390 kB     00:00    
(7/19): lm_sensors-libs-3.6.0-8.fc34.x86_64.rpm 361 kB/s |  41 kB     00:00    
(8/19): perl-Compress-Raw-Bzip2-2.101-3.fc34.x8 682 kB/s |  34 kB     00:00    
(9/19): perl-Compress-Raw-Zlib-2.101-3.fc34.x86 1.2 MB/s |  61 kB     00:00    
(10/19): perl-JSON-XS-4.03-3.fc34.x86_64.rpm    2.0 MB/s | 110 kB     00:00    
(11/19): perl-Math-BigInt-1.9998.18-458.fc34.no 3.4 MB/s | 190 kB     00:00    
(12/19): perl-Cpanel-JSON-XS-4.25-2.fc34.x86_64 1.1 MB/s | 152 kB     00:00    
(13/19): perl-Types-Serialiser-1.01-2.fc34.noar 493 kB/s |  20 kB     00:00    
(14/19): perl-XML-Dumper-0.81-39.fc34.noarch.rp 295 kB/s |  26 kB     00:00    
(15/19): perl-XML-Parser-2.46-7.fc34.x86_64.rpm 3.0 MB/s | 233 kB     00:00    
(16/19): perl-IO-Compress-2.102-2.fc34.noarch.r 977 kB/s | 256 kB     00:00    
(17/19): perl-common-sense-3.7.5-5.fc34.x86_64. 546 kB/s |  32 kB     00:00    
(18/19): xrandr-1.5.1-2.fc34.x86_64.rpm         1.2 MB/s |  45 kB     00:00    
(19/19): wmctrl-1.07-30.fc34.x86_64.rpm         281 kB/s |  35 kB     00:00    
--------------------------------------------------------------------------------
Total                                           2.2 MB/s | 4.2 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : perl-common-sense-3.7.5-5.fc34.x86_64                 1/19 
  Installing       : perl-Types-Serialiser-1.01-2.fc34.noarch              2/19 
  Installing       : perl-JSON-XS-1:4.03-3.fc34.x86_64                     3/19 
  Installing       : xrandr-1.5.1-2.fc34.x86_64                            4/19 
  Installing       : wmctrl-1.07-30.fc34.x86_64                            5/19 
  Installing       : perl-XML-Parser-2.46-7.fc34.x86_64                    6/19 
  Installing       : perl-Compress-Raw-Zlib-2.101-3.fc34.x86_64            7/19 
  Installing       : perl-Compress-Raw-Bzip2-2.101-3.fc34.x86_64           8/19 
  Installing       : perl-IO-Compress-2.102-2.fc34.noarch                  9/19 
  Installing       : perl-XML-Dumper-0.81-39.fc34.noarch                  10/19 
  Installing       : lm_sensors-libs-3.6.0-8.fc34.x86_64                  11/19 
  Installing       : lm_sensors-3.6.0-8.fc34.x86_64                       12/19 
  Running scriptlet: lm_sensors-3.6.0-8.fc34.x86_64                       12/19 
Created symlink /etc/systemd/system/multi-user.target.wants/lm_sensors.service → /usr/lib/systemd/system/lm_sensors.service.

  Installing       : ipmitool-1.8.18-21.fc34.x86_64                       13/19 
  Installing       : hddtemp-0.3-0.47.beta15.fc34.x86_64                  14/19 
  Running scriptlet: hddtemp-0.3-0.47.beta15.fc34.x86_64                  14/19 
  Installing       : perl-Math-Complex-1.59-477.fc34.noarch               15/19 
  Installing       : perl-Math-BigInt-1:1.9998.18-458.fc34.noarch         16/19 
  Installing       : perl-Cpanel-JSON-XS-4.25-2.fc34.x86_64               17/19 
  Installing       : freeipmi-1.6.8-1.fc34.x86_64                         18/19 
  Installing       : inxi-3.3.06-1.fc34.noarch                            19/19 
  Running scriptlet: inxi-3.3.06-1.fc34.noarch                            19/19 
  Verifying        : freeipmi-1.6.8-1.fc34.x86_64                          1/19 
  Verifying        : inxi-3.3.06-1.fc34.noarch                             2/19 
  Verifying        : perl-Math-Complex-1.59-477.fc34.noarch                3/19 
  Verifying        : hddtemp-0.3-0.47.beta15.fc34.x86_64                   4/19 
  Verifying        : ipmitool-1.8.18-21.fc34.x86_64                        5/19 
  Verifying        : lm_sensors-3.6.0-8.fc34.x86_64                        6/19 
  Verifying        : lm_sensors-libs-3.6.0-8.fc34.x86_64                   7/19 
  Verifying        : perl-Compress-Raw-Bzip2-2.101-3.fc34.x86_64           8/19 
  Verifying        : perl-Compress-Raw-Zlib-2.101-3.fc34.x86_64            9/19 
  Verifying        : perl-Cpanel-JSON-XS-4.25-2.fc34.x86_64               10/19 
  Verifying        : perl-IO-Compress-2.102-2.fc34.noarch                 11/19 
  Verifying        : perl-JSON-XS-1:4.03-3.fc34.x86_64                    12/19 
  Verifying        : perl-Math-BigInt-1:1.9998.18-458.fc34.noarch         13/19 
  Verifying        : perl-Types-Serialiser-1.01-2.fc34.noarch             14/19 
  Verifying        : perl-XML-Dumper-0.81-39.fc34.noarch                  15/19 
  Verifying        : perl-XML-Parser-2.46-7.fc34.x86_64                   16/19 
  Verifying        : perl-common-sense-3.7.5-5.fc34.x86_64                17/19 
  Verifying        : wmctrl-1.07-30.fc34.x86_64                           18/19 
  Verifying        : xrandr-1.5.1-2.fc34.x86_64                           19/19 

Installed:
  freeipmi-1.6.8-1.fc34.x86_64                                                  
  hddtemp-0.3-0.47.beta15.fc34.x86_64                                           
  inxi-3.3.06-1.fc34.noarch                                                     
  ipmitool-1.8.18-21.fc34.x86_64                                                
  lm_sensors-3.6.0-8.fc34.x86_64                                                
  lm_sensors-libs-3.6.0-8.fc34.x86_64                                           
  perl-Compress-Raw-Bzip2-2.101-3.fc34.x86_64                                   
  perl-Compress-Raw-Zlib-2.101-3.fc34.x86_64                                    
  perl-Cpanel-JSON-XS-4.25-2.fc34.x86_64                                        
  perl-IO-Compress-2.102-2.fc34.noarch                                          
  perl-JSON-XS-1:4.03-3.fc34.x86_64                                             
  perl-Math-BigInt-1:1.9998.18-458.fc34.noarch                                  
  perl-Math-Complex-1.59-477.fc34.noarch                                        
  perl-Types-Serialiser-1.01-2.fc34.noarch                                      
  perl-XML-Dumper-0.81-39.fc34.noarch                                           
  perl-XML-Parser-2.46-7.fc34.x86_64                                            
  perl-common-sense-3.7.5-5.fc34.x86_64                                         
  wmctrl-1.07-30.fc34.x86_64                                                    
  xrandr-1.5.1-2.fc34.x86_64                                                    

Complete!

[liveuser@localhost-live ~]$ inxi -Fzx

System:
  Kernel: 5.11.12-300.fc34.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 2.35.1-41.fc34 Desktop: GNOME 40.0 
  Distro: Fedora release 34 (Thirty Four) 
Machine:
  Type: Laptop System: Acer product: Aspire A515-51 v: V2.02 
  serial: <filter> 
  Mobo: KBL model: Charmander_KL v: V2.02 serial: <filter> 
  UEFI-[Legacy]: Insyde v: 2.02 date: 01/03/2019 
Battery:
  ID-1: BAT1 charge: 44.1 Wh (100.0%) condition: 44.1/48.9 Wh (90.1%) 
  volts: 16.8 min: 15.2 model: COMPAL 0000000000000000 status: Full 
CPU:
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check rev: A cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 28800 
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus-ID: 00:02.0 
  Device-2: Quanta HD Webcam type: USB driver: uvcvideo bus-ID: 1-7:5 
  Display: wayland server: X.Org 1.21.1.1 compositor: gnome-shell driver: 
  loaded: i915 note: n/a (using device driver) - try sudo/root 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.2 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
  Sound Server-1: ALSA v: k5.11.12-300.fc34.x86_64 running: yes 
  Sound Server-2: PipeWire v: 0.3.25 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus-ID: 01:00.1 
  IF: enp1s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus-ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
Bluetooth:
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB 
  driver: btusb v: 0.8 bus-ID: 1-5:4 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
Drives:
  Local Storage: total: 946.85 GiB used: 10.86 GiB (1.1%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: MEMPEK1J016GA size: 13.41 GiB 
  temp: 30.9 C 
  ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  ID-3: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 1.92 GiB 
Partition:
  ID-1: / size: 7.32 GiB used: 5.64 GiB (77.0%) fs: ext4 dev: /dev/dm-0 
  mapped: live-rw 
Swap:
  ID-1: swap-1 type: zram size: 3.71 GiB used: 13.5 MiB (0.4%) 
  dev: /dev/zram0 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 299 Uptime: 5m Memory: 3.71 GiB used: 2.67 GiB (71.9%) 
  Init: systemd runlevel: 5 Compilers: gcc: 11.0.1 Packages: N/A 
  note: see --pkg Shell: Bash v: 5.1.0 inxi: 3.3.06

Looking at the readout closely, I can see the drive ID you mentioned that could possibly be the problem! I feel like I’m so close to fixing my laptop, yet I’m not sure what to do next. Thank you so very much for your assistance!! sending a virtual hug

Thank you, @hhlp !!

I wish I knew how to do that edit. :sweat_smile:

Please check this in your bios.

https://discussion.fedoraproject.org/t/fedora-31-and-32-anaconda-does-not-see-my-nvme-m-2-drives/68056/23?u=ilikelinux

Have you checked if there is a new firmware for your laptop? This might help if the above tip not solves your problem.

In the editor press </> and paste your code there.
Alternatively you can use the backtick (3 without blanks) ``` before and after to mark a text as “pre-formatted text”

1 Like

Ooohhh… Thank you! I’ll use that option for editing from now on.

As for the fix? I have had my laptop set to AHCI the entire time I’ve been trying to do this… That’s why I’m so confused as to why it’s not detecting the drive.

I’m considering formatting the RAID drive also as I don’t really need it. Would that hurt my computer?

Ah ok … do you have a software raid? If yes, that’s why anaconda can’t see the drive. If you want software raid you can make it with Btrfs.

It will not hurt … if you format it.

1 Like