The hard disk allocated to put Fedora on does not appear

Today I tried to install Fedora 38 on my laptop alongside Windows, but a problem arose for me and I have not found a solution for it yet, which is that the disk that I deleted to put Fedora on it does not appear. Then I stopped BitLocker and had the same problem. Then I changed the SATA settings and the same problem was not solved Laptop type
Dell latitude e5440

See: Dell BIOS setting for linux


I tried this method and the same thing appears on my drive with a space of 1007 KB

This looks like Bitlocker is still active, so Fedora can’t see the partition. In Windows, try assigning a drive letter to the free space and make sure bitlocker is off.

The third image you post is too blurry to read here. If you boot into the Live system you can use the Disks tool to compare what Fedora sees with what Windows shows. Use command-line tools to create text files that can be pasted into a forum post (use the </> button or bracket the text with triple backquotes). Start with sudo fdisk -l.

1 Like

The empty hard drive will not be read at all

Does the drive appear in the Windows Storage manager? Your image only shows an unallocated 40GB in Disk0 and a removable disk which I assume is the Fedora Installer USB key. The latest image doesn’t appear to match your Windows image – there is no 40GB empty partition.

I have seen cases where a system had both SATA and M.2 drive bays, but did not support NVME drives in the M.2 bay.

I’m fed up with this situation. I tried all the solutions, but none of them worked. It seems like I have to go back to another distribution

The difference in support for mass storage devices and other distros between Fedora and other distros is mostly in the kernel. This means the issue may reappear when other distros upgrade the kernel. If other distributions recognize the drive, it would be helpful to see the details. A bug report would be the best way to ensure the problem is addressed.

I found the solution
Yes, I converted the hard drive from… GPT the MBR And turned off from UFI To my heritage legacy
And I stayed
Sata Options AHCI

Glad you got it workng. It would be helpful to mention some system details (vendor, BIOS version) for others who encounter the problem.

1 Like

Some systems provide an M.2 port as a SATA device. The ones that support the nvme devices are an M.2 PCIe connection.

How to check PCI M.2 NVME SSD compatibility with your pc says:

simply having an M.2 Slot doesn’t guarantee NVMe compatibility. M.2 was designed to support USB 3.0, SATA, and PCIe, and most early M.2 slots only supported SATA.

The article refers you to the manual for your motherboard to determine what it supports.