Raspberry Pi 5

Tried to install F40 on Pi5.

What I did:

  1. Copy Fedora-Server-40-1.14.aarch64.raw.xz onto SD card
  2. manually add usb_max_current_enable=1 under [pi5] section in config.txt
  3. boot Pi5

What I got:

Image boots Basic System to “basic.target”
Some timeout
[…] dracut-initqueue[525]: Warning: dracut-initqueue: timeout, still wating for following initqueue hooks:
[…] dracut-initqueue[525]: Warning: /lib/dracut/hooks/initqueue/finished/devexists-\x2fdev\x2ffedora\x2froot.sh: 5 -e “/dev/fedora/root” ]"

Seems that dracut looks for the lvm volume /dev/fedora/root (confirmed on an Intel reference machine)


The SD card holds:

Device Boot Start End Sectors Size Id Type
/dev/mmcblk0p1 * 2048 1230847 1228800 600M 6 FAT16
/dev/mmcblk0p2 1230848 3327999 2097152 1G 83 Linux
/dev/mmcblk0p3 3328000 14680063 11352064 5.4G 8e Linux LVM

Disk /dev/mapper/fedora-root: 5.41 GiB, 5809111040 bytes, 11345920 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

(so this looks correct)

$ sudo lvdisplay
— Logical volume —
LV Path /dev/fedora/root
LV Name root
VG Name fedora
LV UUID axrwVq-auP3-pNvE-SKU8-ARgJ-4hyA-igejy3
LV Write Access read/write
LV Creation host, time localhost.localdomain, 2024-04-15 01:02:29 +0200
LV Status available
'# open 0
LV Size 5.41 GiB
Current LE 1385
Segments 1
Allocation inherit
Read ahead sectors auto
'- currently set to 256
Block device 253:0

(run on Pi under Ubuntu)

Mounting /dev/mmcblk0p2 (intermediate linux bootloader), in grub2/grub.cfg, Section 10_linux

'### BEGIN /etc/grub.d/10_linux ###
insmod part_msdos
insmod xfs
search --no-floppy --fs-uuid --set=root 5de72da0-eb7e-46c3-9bfc-c1ddbe6e8800
insmod part_msdos
insmod fat
search --no-floppy --fs-uuid --set=boot 087A-FAF0

(does this GUID need to be the same as the LV GUID?)


Pi boots from /dev/mmcblk0p1 DOS partion into Linux /dev/mmcblk0p2
Linux looks for root logical volume in /dev/mmcblk0p3 but fails (times out)
LV /dev/fedora/root exists

Not sure where the problem lies.
Any suggestions?

Last update I read about rpi5 support on the fedora arm mailing list is that there are specific kernel patches that need to be upstreamed still.

It is known that f40 cannot complete boot as it cannot find the storage.
So until someone does that work on the kernel side it will not work.

Hi Barry,
thanks for your comment.
As Fedora documentation is so bad (a clear status is not given), I tried to install.
I could not find any indication that F40 cannot complete booting (Links appreciated)

I will add more findings to my post

https://fedoraproject.org/wiki/Architectures/ARM/Raspberry_Pi seems pretty clear: it lists supported Pis, and specifically does not mention the 5 at all.

Here’s a detailed status: Details on Raspberry Pi 5 support timelines - arm - Fedora Mailing-Lists

Some more findings:

Mounting /dev/mapper/fedora-root (again from a reliable Pi5/Ubuntu combination):

I removed all rhgb quite entries in Grub configs. Now I can see a little more of the boot process.

After reaching basic.target, the console logs reveal problems with:

  • cooling fan
  • power button
  • some gpio pins (may be corrected changing eeprom settings)
  • voltage regulation (I set usb_max_current_enable=1)
  • spi
  • wireless lan

All that seems to cause irritation but no stall.

Then dracut kicks in.

It waits for some initqueue hooks and refers to /lib/dracut/hooks/… . The directory /lib/dracut/hooks does not exist (not on the Pi, neither on my reference box).

Here the magic happens that I cannot explain nor understand without further information.

Any hints appreciated.

Hi Adam,

thanks for your links.
However, neither is the information clear (it just does not mention Pi5) nor detailed enough to be helpful (I fiddle with the kernel to make it minimally bootable by the end of April?)

I would expect Fedora to officially comment on status and timeline on their website (in the docs, they do have an outdated Pi SoC section).

I’m afraid we are not going to meet those expectations. A full refund will be issued!

1 Like

Just found reference in the related topic section.

It seems that this problem existed ever since F30. I’m more so surprised that this issue then still exists.

The hooks aren’t found because the kernel cannot find the storage. Barry told you this. The mail I linked you to says this: “We have the firmware (bcm/u-boot) pieces in place in Fedora 40 and the
kernel will start to boot and you get serial console output except you end up at a dracut prompt due to lack of storage.”

The Pi 5 is not supported. Unless you patch the kernel yourself, it is not going to work. Ubuntu is carrying non-upstreamable patches to make it work. Fedora does not do this, by policy; we enable new ARM devices by helping get patches to support them upstreamed.

A full refund will be issued!

Thanks, appreciated