Raspberry Pi 4 uboot cant find its own partition [solved]

I installed Fedora Server 37 onto a Raspberry Pi 4 because I heard it was supported. It was running perfectly until yesterday, when it refused to boot. After connecting it to a display, I see that uboot loads but cannot find mmc:0, which is the partition uboot is installed to. This is very strange becuase the RPi firmware can read the partion, but uboot can not. Other linux distros with the mainline kernel can also read the microSD card on the same hardware, also using uboot. This is rev. 1.4, which used to have uboot problems, but I thought it worked in fedora. I also ran fsck on all of my partions, and it said there is nothing wrong. I can chroot into the installation to fix it. Can someone help me.

I solved the problem now, posting for anyone who reads this. Sometimes the shim binary /boot/efi/EFI/BOOT/BOOTAA64.EFI can not be installed by the shime-aa64 package. To fix it reinstall the shim package, or copy the shim there from a different install/distro.

1 Like