Raspberry Pi 4 and Fedora 33 Beta

Does Fedora 33 beta support the Raspbery Pi 4?

1 Like

Same as F32, very short answer: no



I have the Raspberry Pi 4 running Fedora 33, kernel 5.8.17-300, as a headless server. Wifi and ethernet work. Fedora will have better support for the Raspberry Pi 4 with kernel5.9.

Raspberry Pi 4 still not feature complete with the upstream kernel but it is getting there. Some changes to VC4 DRM is expected to be merged into the 5.10 kernel which should improve support for two hdmi ports in the Raspberry Pi 4.


Janolaf - I am wondering what steps you followed to install F33 as a headless server on an RPI4. I cannot get the OS to boot correctly.


The big gotcha is Raspberry Pi 4’s will not boot unless connected to a monitor. You will have to add hdmi_force_hotplug=1 to /boot/efi/config.txt to force a Raspberry Pi 4 to boot headless. You can do this before or after install.

I used a monitor to finish the install on the Raspberry Pi 4.

These instructions are for completeness. I have tested this with the Arm64 server raw image and the IoT image.

This is to install Fedora 33 Server.

Download arm server raw image on your computer. The direct link

Install arm-image-installer:
dnf install arm-image-installer

In the directory holding the arm64 raw image type:
sudo arm-image-installer --image=Fedora-Server-33-1.3.aarch64.raw.xz --target=rpi4 --media=/dev/sdx --addkey=/home/youruser/.ssh/id_topsecret.pub --resizefs

  • --media should point to the microsd card. arm-image-install will format the card and requires root permissions (use sudo)
  • --resizefs will increase the size of root parition to avalible space on the card. Fedora will make a 4GB root partiton on a 64GB microsd card which I consider too small. You can of course resize after install.
  • --addkey is optional

Insert microsd card into Raspberry Pi 4 connected to monitor to finish the install.


Janolaf - thank you very much for your reply. It turns out I basically ended up in almost the same place via trial and error. I tried to document the steps I follow to install F33 minimal on a microsSD at F33 Headless and RPI 4 - Brief How To (Revised) - Raspberry Pi Forums. My goal was a headless install and have been successful. The hdmi_force_hotplug option was not needed in the process I worked out. I am still struggling to get this to work from a USB flash or USB SSD (still working headless as I do not have a monitor I can dedicate to this task).


1 Like

You could look into this. He installs Fedora using Server Ready (UEFI) and usb.

Thanks. I will review the information at the link.


However I was able to install Fedora-Minimal-33 on the Raspberry Pi 4 without any weird hack, by simply using:

sudo arm-image-installer --image=Fedora-Minimal-33-1.3.aarch64.raw.xz \
--media=/dev/mmcblkX --resizefs --target=rpi4

I didn’t test any DE, only the terminal.
It works pretty well. WiFi works, USB3 (at least with an USB stick) works.

I encountered only these issues so far:

  • The RPi doesn’t boot if there is not an HDMI display attached
    • To solve, add hdmi_force_hotplug=1 to /boot/efi/config.txt
  • There was no link on the Ethernet port
    • To solve, install ethtool and issue:
      ethtool -s eth0 autoneg off speed 100 duplex full
1 Like

Thanks. I have been able to install and run F33 Minimal using pretty much the same process on a microSD. I documented the steps I used at https://www.raspberrypi.org/forums/viewtopic.php?f=51&t=292630. I have not yet been successful at booting headless from a USB attached device (flash or SSD) with an interesting exception.

@janolof linked to fwmotion.com and a post by Robert for F33 server. There is also a post for F33 Workstation which I followed (substituting F33 minimal) on to a USB flash drive. That actually booted but fails to start after a reboot. I tried three separate installs and had the same result. Speculation on the fedora-arm irc channel focused on the possibility that the UEFI settings were not being set correctly which seems to be possible as efibootmng does not return any useful information on the RPi4 from fedora. I have been working headless as I do not have a monitor to use with the RPi4 except an old Samsung. The microHDMI - DVI cable works when booting from flash but somehow is corrupting all boots from USB.

Thank you very much! In other places, they mistakenly instruct people to add this command in /boot/config.txt

Now I finally got my Fedora running without HDMI connected to it.


I have installed per the instructions here:


I do not have


and it boots just fine with no hdmi.

The only issue I have having now is after an update, seems that wifi is broken… :frowning: