Problem with install exe file with wine

Hi everybody,

I want to install a exe file with wine. i have a autorun.exe , SDCheck.exe and SDSSwitch.exe.

when i run autorun.exe with wine program loader, Nothing happens. how to solve it?

I am using program called “bottles” to run windows programs on linux. It seems to me that it is quite good. You can install it from flathub. It should be more secure than using wine installed directly.
After installing bottles and needed dependencies for a little more security I disable network access for it with flatpak managing program “flatseal”.
When you run a program in “bottles” you can choose to run it with terminal - this way you might see what errors occur and what dependencies needed.

I installed wine and bottles. but i don’t install java!!!. how to install it?

Have you tried to download java and install it in created bottle by pressing “run executable…”?

sudo dnf install java-latest-openjdk if you want the latest java runtime installed, which is version 21 atm. Just replace the ‘latest’ with the version you want if version specificity is required. ie if desired to run java 11 runtime you would do sudo dnf install java-11-openjdk.

I install some java and qml package, erlier problem was solved. but i see a problem with install a database. have u any idea?

No, not really. This seems a Windows thing not a Fedora thing to me.

i solved this error with Increase disk space. but i faced new error.

error : error executing the QML batch file

have u any idea?