PopOS! Theme on Fedora

Good day!

Has anyone compiled and installed PopOS! gtk and icon theme on Fedora yet? I would appreciate if someone could point me to a working guide. Thanks!

1 Like

Ohh! another nice them and icons:

did you tried this:

See section 8.

Just download the script and Done…


  1. Download Box
  2. chmod +x install-popOS-theme.sh
  3. ./install-popOS-theme.sh


sudo dnf install inkscape optipng gtk-murrine-engine sassc
git clone https://github.com/pop-os/gtk-theme.git
cd gtk-theme
make assets
sudo make install

Regards., Good Look


Thanks @hhlp

that script does the same as the steps listed below…

This seemed very obvious and I tried it but make was giving me an error that I could neither understand nor solve. (Not in front of that machine right now, so can’t reproduce, but will paste details later).

1 Like

I decided to give this a quick try in a F33 VM to see if I can reproduce the issue I had on my friend’s machine. Same thing.

Make returns:

 make: *** No targets specified and no makefile found.  Stop.

I found a COPR that works fine: jhaygood86/pop-os-gtk-theme Copr

sudo dnf copr enable jhaygood86/pop-os-gtk-theme 
sudo dnf install pop-os-gtk3-theme
1 Like


not make now too old post, now is building with meson

see here installing from source: → https://github.com/pop-os/gtk-theme#installation-from-git-source


sudo dnf install inkscape optipng gtk-murrine-engine sassc
sudo apt remove pop-gtk-theme
sudo rm -rf /usr/share/themes/Pop*
rm -rf ~/.local/share/themes/Pop*
rm -rf ~/.themes/Pop*
  1. Generate the theme files.
meson build && cd build
  1. Install the theme.
ninja install


ninja install seems to expect root privileges. I would prefer a user-only installation.

1 Like

run meson -Dprefix=$HOME/.local build instead of meson build

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.