Gnome cursor theme

I noticed that for some reason in Fedora (i’m using Fedora-29-Workstation) I’m not able to change the theme of the cursor.
As I used to do in other distros, I changed the theme in gnome-tweak-tool. It seems to be working correctly as I can see the changes in dconf, but even after logging out and back in the change simply isn’t happening (logging out for cursor theme shouldn’t be necessary).

I tried capitaine-cursors-r3 and manjaros xcursor-breeze and xcursor-breeze-snow. Non of them work.

Anybody has the same issue. Any idea what might be causing this?

Welcome! @phalkon

The cursors are installed in the /usr/share/icons folder. User specific cursor themes can be installed in ~/.local/share/icons folder.

You can install capitaine with:

sudo dnf copr enable tcg/themes
sudo dnf install la-capitaine-cursor-theme

Then configure in gnome-tweak

How did you install the others?


To change the theme use gnome-tweaks or set the configuration directly with:

gsettings set org.gnome.desktop.interface cursor-theme cursor_theme_name


1 Like

Ok, thanks for the help, I figured it out. :]

I didn’t really want to add repo just to install theme, but i went ahead and follow the instructions and it worked. So what did I do differently?
I kept my themes in ~/.local/share/icons. It should have worked anyway, in fact, gnome-tweak-tool even saw the themes. When I moved them to /usr/share/icons it worked.

Now I’m still wondering why is that, but I’m glad it’s working now. Thanks for the help again. :]

1 Like