Refresh icon cache in GNOME


I’ve used this cursor theme for some time Flatbed Cursors - The issue is that I now use the default Adwaita cursor theme, however the following icon still remains and I can’t get rid of it:


For example, it appears every time I start gnome-boxes:

I tried to execute:

sudo touch /usr/share/icons/Adwaita
sudo gtk-update-icon-cache -f /usr/share/icons/Adwaita

but it still remains. Any idea on how to restore the default Adwaita cursor theme?


Check that not another is not remaining in the gnome-tweeks app as cursor theme. In the last case you can restore to default but first try reinstall the package:

sudo dnf reinstall adwaita-cursor-theme

Maybe there are files into your ~/.cache ~/.config ~/.local folders that can be impeding the change.

How one last option if nothing is working you can go to a default state of gnome (you will lose every change you did, extensions , etc… all with the followed command sudo dconf reset -f / but really i don’t recommend you to use it because is too much to only because a cursor theme (I used it in others distros to delete all personalization of gnome-desktop that they had done).

Try reinstall theme and clean config files from the theme in the hide folders of home, or try fix the changes through gnome-tweeks.