GNOME Flatpak apps on Qt use the wrong icons

The packages

adwaita-cursor-theme-45.0-1.fc39.noarch
adwaita-icon-theme-45.0-1.fc39.noarch
adwaita-gtk2-theme-3.28-17.fc39.x86_64
libadwaita-1.4.3-2.fc39.x86_64

are installed, but GNOME Flatpaks still look like this:

grafik


Note that Thunderbird switched between the breeze CSD icons and generic icons, now using the breeze icons. Librewolf on the other hand uses some generic icons, see here

grafik

(top: Thunderbird, bottom: Librewolf)

But these use their own toolkit and use the native toolkit for decorations, this is different.


How can I force flatpak GTK apps to use Adwaita icons, and why is this not done by default?

By default, GTK flatpak apps should follow the GNOME icon theme, via xdg-desktop-portal-gtk. What is it set to?:

gsettings get org.gnome.desktop.interface icon-theme

Have you set any relevant overrides? Without an override set, there’s no other mechanism that could be used on Wayland (X is a different story).

1 Like

aaha!

'breeze'

This fixes it!

gsettings set org.gnome.desktop.interface icon-theme Adwaita 

Now the question, I dont think this is an issue on my system. I should try on a clean install. But should this be set to Adwaita by default?

This changes all of the icons mentioned above.

Last I checked, KDE didn’t set anything in dconf, but that may have changed.

KDE can configure GNOME applications theme in System Settings → Appearance → GNOME/GTK Application Style. Specifically, it sets up the GTK theme in xdg-config/gtk-3.0 and gtk-4.0. I believe this is the default behavior to make GTK applications look native.
Some GTK applications, like LibreWolf Flatpak, do not have access to these configuration files by default, so it just uses generic icons.

1 Like

No flatpak apps should have access to those directories by default.

Is it bad to allow applications to pick up the GTK theme from ‘xdg-config/gtk-3.0:ro’? I believe LibreOffice Flatpak does this by default.

It’s not ideal, but it’s probably not super harmful. Surprisingly, the reason it was added to LibreOffiice was to allow the file chooser to show bookmarks. The proper solution would be to use the File Chooser portal: 159311 – Use xdg-desktop portals instead of static filesystem permissions

2 Likes

Plasmas default seems to be ‘breeze’

There must be a packaging issue in Kinoite.

https://pagure.io/fedora-kde/SIG/issue/497