Cursor disappear with gnome teminal

HI everyone, since yesterday my mouse started to not being visible in gnome-terminal once i start writing. I didn’t change anything so i really don’t know what happened. Is there any settings to not
hide it while writing?
P.S. I am using Fedora 37 with Gnome 43

I can confirm this. I do not object this behavior myself. Note it happens also in other GTK3 and likely also GTK4 applications. I do not know of a setting.

Update: looks like it is an issue with gnome tweaks and theming cursors. I tried various cursor themes and all have the same problem except for the default one. What can i do? I really don’t like adwaita cursor :frowning:

SOLUTION: Apparently this issue happens only to cursors stored in /home/USERNAME/.icons, the solution is to move everything in /usr/share/icons
Solution found on reddit


Good you solved this, but that does not fit my experience. I am using the default cursor, and I see this “issue” in GTK apps.

Cheers, that solved it for me too. I had the same problem where my custom cursor disappeared in certain apps.

However, it must be because of some recent change, because they worked fine before, even though they were stored in /home/USERNAME/icons/. It only broke a couple of days ago.

Nevertheless, moving them to /usr/share/icons fixed it for me, thank you.