Please help me getting my tablet to work

I have a Wacom Intuos CTL-490 tablet I wanted to use with Gimp and MyPaint and it has been a nightmare trying to get it to work.
Right on the Settings>Wacom Tablet>Test Your Settings my stylus pointer doesn’t show on the area to test it.
On Mypaint the screen becomes unresponsive when opening the brush selection dialog on the bottom bar and drawing straight lines or ellipses start from where the mouse pointer is. I tried to run MyPaint with export GDK_BACKEND=X11 and it solved those problems, so I thought I fixed it, but the stylus pointer doesn’t show on fullscreen and after running it a few times this way it started giving an error and I can’t launch it anymore this way.
On Gimp Configure Input Devices I have set both tablet and stylus to Screen Mode so it detects pressure, but the stylus pointer disappears when it leaves the canvas and the mouse pointer doesn’t work in the canvas.
I tried switching my session to X11 but it scrambles all of my tablet’s keymaps and the top right button isn’t detected at all, it doesn’t show an input on xev. I tried using xsetwacom to reset the keymaps but that didn’t work either. Also Gimp crashes soon as I click the canvas on a X11 session.

I’m out of ideas, I tried getting help on IRC and Discord but nobody answers and ChatGPT didn’t help either.
I’m using Fedora 38, Gnome 44.2, Wayland, the model is CTL490DW it’s listed as CTL-490 Intuos Draw small on Device IDs · linuxwacom/input-wacom Wiki · GitHub so it should be supported.

you have been asked several times on irc for more info and you never respond

I haven’t received any messages on IRC, you can ask here.