Wacom tablet on Wayland

I recently upgraded to F40. I usually use KDE/Plasma because some things didn’t work under Gnome - like my Wacom tablet.

Since upgrading to F40 the tablet has been acting up under KDE. The pointer is trapped on one monitor, input isn’t read, and the virtual keyboard pops up without warning. So I tried Gnome.

The tablet works under Gnome Classic and Gnome on Xorg but not Gnome on Wayland making it looks like the problem is Wayland.

Are there any fixes to get the tablet to work under Wayland or should I just switch to Gnome classic until the next release?

Do you have Linux drivers installed for your specific tablet? Can you post the model of your Wacom ?

If you run into trouble there are some pretty reliable drivers for Wacom (specifically)

Unlike my HUION KAMVAS 16 Pro

I thought the drivers had been added to the Linux system a few years back. It worked fine from F29-F39…. A GitHub article I found earlier seemed to say the Wacom drivers were dependent on Xorg and did not function under Wayland. I’ll look at it again later.

The tablet is an old Bamboo Fun, 6x8, with stylus and buttons.

1 Like

If your Wacom works under X11 flawlessly, I think you’ll need to stick to that since you are on KDE.
I don’t use KDE, but I think they jjust went Wayland for F40. So you would need to get X11 to work under Plasma6. Maybe someone from the kde SIG can come in and give some advice.

I’ll dig up some information for you in hopes to get that fixed for you and other creators. It’s a big deal IMO.

I’ve had so much trouble with my HUION KAMVAS on Wayland, I basically abandoned a 16" Tablet :laughing:

Thanks. I can use Gnome on Xorg for now. Getting the current KDE to work on Xorg seems like more than I want to deal with. My program seems to work with the current release (it didn’t on earlier ones).

1 Like

Sorry about that, I’m not a KDE user, and have only seen here on the forums that there are packages that need to be installed. As for Gnome, if you can use Gnome Classic, or Gnome on Xorg to get by, that might be the best solution.

This is a big issue with Wayland and moves to other forms of OS as well. Creators are always the last in line.

In another thread it was suggested I add “plasma-workspace-x11”. I added it through dnfdragora and rebooted. I then had an option for using Plasma on Xorg at login. Wacom tablet now works, mouse slowness is gone, and kcalc again accepts keyboard input.

1 Like

Thanks for that, I’m sure this information will help many KDE users.