Pano Gnome Extension, gda not found

If you install Pano from Pano - Clipboard Manager - GNOME Shell Extensions

you get the following error Requiring Gda, version none: Typelib file for namespace 'Gda' (any version) not found

Some confusion later, I realised this is because Fedora 39 ships libgda5 where Pano wants libgda6

I just want a clipboard manager that supports images and actually works.

Fedora has both. libgda is Gda-6.0, libgda5 is Gda-5.0. This extension is apparently designed to work with either.

Neither of those are installed by default though. Did you sudo dnf install libgda libgda-sqlite as directed and restart your session?

Yeah got there in the end thanks. I have installed those packages but am still getting the error.

The extensions screen really needs a reload button rather than forcing me to uninstall and reinstall every time.

$ sudo dnf repoquery -l libgda | grep type
Last metadata expiration check: 2:58:46 ago on Sun 07 Jan 2024 09:47:54.

Updated the title.

Which process should I be trying to strace to see what it’s trying to load? (I found the gnome-shell disable/enable command but it’s not clear to me if that’s actually reloading anything)

Did you restart your session after installing those packages?

Extensions run as part of the gnome-shell process. Once an extension has failed to load, it’s prudent to restart to avoid any leftover inconsistent state.

I have now, and I get GLib.Error gda_config_error: No provider 'SQLite' installed

Package libgda-sqlite-1:6.0.0-6.fc39.x86_64 is already installed.

Perhaps there should be something in the UI to tell me to log out and log back in after installing an extension.

It works here in a VM. I can only reproduce that error by removing libgda-sqlite.

I don’t don’t think it likely, but maybe it’s preferentially using libgda5, so if you have that installed, you could try removing that package (and logging out again).

After removing libgda5 and logging out I am back to Requiring Gda, version none: Typelib file for namespace 'Gda' (any version) not found

Thanks for your patience while debugging this one.

That’s odd. Does /usr/lib64/girepository-1.0/Gda-6.0.typelib exist on disk? Maybe some sort of cache is in play, but I don’t know of one.

As a workaround, installing libgda5 and libgda5-sqlite would probably work.

That was weird - that typelib was missing. I ran dnf reinstall libgda and rebooted out of frustration and Pano is now working.

Now I only have Memory leak and high cpu usage due to image preview. · Issue #252 · oae/gnome-shell-pano · GitHub to look forward to :wink:

Thanks for all your help.

I believe with better error messages and debugging facilities I could have resolved this faster.

Sounds like feedback for the pano maintainter.
You could find the pano project and raise an issue there.

Tried with GNOME, didn’t phrase it well enough, issue closed. Think I’ve burned all the energy I want to on this.