Can't install GNOME extensions from Extension Manager

Using Fedora 37 Workstation. I was using Extension Manager to browse and install extensions. The only one I had was ‘dash to dock’ since it allows scaling it down otherwise it looks a bit big. Anyway, after the latest updates (done through the Software app), the dash to dock disappeared.

Going into the Extension Manager shows no user-installed extensions. So I browse to ‘dash to dock’. Clicking on the install button brings up a confirmation dialog box, but clicking on install doesn’t do anything, it just basically dismisses the dialog window and that’s it. The extension is quite popular AFAIK, and it’s up to date through GNOME 44 (and of course F37 is using GNOME 43 anyway).

As I said, this happened pretty much after the latest updates to Fedora 37, so I’m guessing that’s what caused this issue.

Next I tried to install another extension, any extension and got the same result. The Extension Manager can browse and bring up the detailed page for the extensions, but can’t/won’t install them.
Any idea what’s going on? As far as migrating to F38, I have the notification showing in my software app, but haven’t pulled the trigger yet. I figured the servers might be a bit slow with too many people pulling from them at the same time.

I believe that Gnome Extensions are handled via the browser ATM. I have had mixed success with the Gnome Extensions app in recent releases. So if you browse to you will see that state of your extensions.

Try to install it in terminal this way:
sudo dnf install gnome-shell-extension-dash-to-dock

The extension manager from flatpak you get like (blue icon):
sudo flatpak install com.mattjakeman.ExtensionManager

The extension manager to browse (green icon) you get:
sudo dnf install gnome-extensions-app

To get more than just the Fedora apps, you have to check “Software” > “Software Repositories”
if is active. Also to the “testing” flatpak repository can be switched on there if necessary.

Screenshot from 2023-04-20 08-41-55


Ok so I ended up installing it using dnf. The outcome is it worked, but doesn’t show up in the Extension Manager as an installed extension.

As an FYI, I initially installed the extension via the Extension Manager app, a few weeks ago. The break was just a couple of days ago, in the last few updates before the release of F38.

I’m now going to update to F38. Will be interesting to see if that breaks the extension again.

I also got it realized this issue. On F38 i got the information I should use the extension manager from flatpak.

You might have to activate first the rpm-fusion repo. before finding it.
Configuration - RPM Fusion

1 Like

Overall the upgrade went ok.
Some things to note:
-the gui method of upgrading to F38 via the Software app failed.
-the dnf method of upgrading (described on Fedora site) worked flawlessly.
-the dash-to-dock extension was still there after the upgrade, and functioning normally. (not surprising since it is up to date and compatible with GNOME44)
-the Extension Manager that I have is from Flatpak, and it is working again now that I have upgraded to F38.

I checked the repositories that are listed in the Software app, the fusion ones are there and activated. I also did the command line that you linked to, it confirmed it is already there, so it didn’t need to do anything.

1 Like

I have seen a few reports of problems with using the software app to upgrade from F37 to F38. So far I have seen no reports of errors using dnf to do the upgrade.

1 Like

I added two options how to install the extension manager, on my request above: