Cannot add extensions via Extension Manager or Gnome shell extensions

Extension manager:

When i try to install extensions from extension manager clicking on the Install button next to an extension has no effect, does not show any warning or the useual install prompt. Application just stays inactive (i.e., Doesn’t do anything)

Gnome Shell Extensions:

With gnome shell extensions, I made sure that i have the gnome shell integration extension for Firefox and chrome added to my browsers (Tried this on both Firefox and a chromium based browser). when i visit the home page of gnome shell extensions no extensions show up but i could search for an extension and get results. WHen i try to install an extension through my browser the ON switch or the install button turns on but doesnt prompt for installation like its supposed to do

Later when i check my installed extensions the one i just tried to add from the browser doesnt show up and as i search again for the extension in the browser it says turned off.

Terminal or Package Manager:

Extensions installed through DNF works perfectly well

I simply can’t add extensions via any other source. This used to work properly but, this issue occurs since i decided to reinstall fedora (I completely wiped off deleted all existing partitions related to fedora and recreated them).

I dont understand why this issue happens if anyone could help its highly appreciated

This must have caused the issue, how did you wipe and recreate?

I can confirm the same issue on firefox 102 and chromium-freeworld.

I had the same thought. Okay here it is,

a BTRFS volume with 2 sub volumes

  • subvolume Root mounted at /
  • subvolume home mounted at /home

an ext4 boot partition mounted at /boot
a system UEFI partition
a swap partition

might this be because i have a seperate home subvolume? i am not sure :thinking:
if you could help me figure out that would be great

Actually the reply above by Joe plus another thread on here about the same problem lead me to believe it’s an issue with the browser extensions most likely. Seems others are having the same problem.

Gnome 42 does not support many of the extensions previously supported in gnome 3.8. I don’t know which extensions you are trying to use, but the upgrade of gnome has left many 3rd party extensions inoperable and it will take time for the developers to get everything back functional.

To echo @computersavvy, this could be specific to the extensions you’re trying to use; could you provide a specific one and double-check GNOME Extensions that it’s compatible with 42?

Even if it’s not officially compatible, there are usually ways to get it working anyway…

I’ve been having the same problem on a fresh Fedora 36 install.

On a side note, I noticed this morning that the update command frequently timed out and that, as of now, I can’t download the Fedora 36 iso from here

Hey @thezel welcome to ask :fedora: please take a minute to read,

If you’re still having issues downloading/updating please start a new topic

The Gnome Extension issue is a bug, it’s being discussed here ERRORS on GNOME Shell block all GNOME Extensions (#5622) · Issues · GNOME / gnome-shell · GitLab

It Impacts everyone running gnome-shell 42.3.1

Does seem like it, Thanks @grumpey.

Call me confused—or lucky, I suppose—but all my extensions are running without issue on 42.3.1…

If you’re installing with dnf or gnome software you’re probably ok.

If you were trying to install from the browser while this was going on it wouldn’t work.

It was corrected this weekend.