Impossible to install extensions...but no error messages


I have F37 installed with gnome, wayland, Firefox and the gnome extension for Firefox. When I install an extension, (clic on “ON/OFF” button), it ask me to download, I accept…but there is nothing installed.

What is my mistake ?


Sometimes the new extensions won’t get enabled until the next time you log into Gnome. There is a new Extensions app in Gnome that will give you that message for that extension, if that’s the case.

1 Like

Yes I installed the Gnome Extension App but it tells nothing about a log off/on. Even if I do that, I have no extensions installed…

I have installed the Flathub version of Gnome Extension. Could it be the problem ?

What I don’t understand is that “chrome-gnome-shell” is required in order to install extensions with Firefox. But I can’t install this package :

david@fedora ~]$ sudo dnf install chrome-gnome-shell
[sudo] Mot de passe de david : 
Dernière vérification de l’expiration des métadonnées effectuée il y a 3:29:06 le mer 25 jan 2023 06:58:28.
Aucune correspondance pour le paramètre: chrome-gnome-shell
Erreur : Impossible de trouver une correspondance: chrome-gnome-shell

Commit - rpms/chrome-gnome-shell - 1dda55ff8cc05aeb05021f21b2057548545939eb -

I didn’t know the name of the package has been changed.

But, I checked and this package is already installed and it doesn’t work

1 Like

Make sure you have followed the instructions from the official guide:

If the issue persists, verify the relevant browser add-on is installed and active.
See also:

I follow everystep and it still not possible to install extensions like “Espresso” for exemple…

is there a way to have an error message ?

Problem solved

The privacy settings of Firefox disable the certificate…