Org.freedesktop.systemd1 issue in Sway

I have layered Sway using rpm-ostree and called systemctl set-default Doing this seems to have broken podman, as the command podman start --attach outputs

Error: OCI runtime error: unable to start container 452ec2ad8b6d382bcf77745e893332e4be6ee4401e8ca318c3413159f1e10d29: sd-bus call: Process org.freedesktop.systemd1 exited with status 1: Input/output error

Any ideas?

Hi, I’m not sure why you need since sway can work with You just need to select the session. If you’re using Gnome, after select user icon, on very bottom right corner there will be present a gear icon. Click it and select sway session.

1 Like

The is not necessary, but is my preference. However, when I have set and select Sway in the login manager (gdm I think), I see the same error.

When I select Gnome this way, the error does not appear. But, if I log into Sway this way, then log out and log in using Gnome, the error returns.

I just tried to install [testcase@fedora ~]$ rpm-ostree install sway on Silverblue and it’s work fine.

Btw, How did you install sway?

1 Like

With rpm-ostree install sway. I am not understanding your screenshot, though, since it looks like it only shows a successful sway installation. I am able to use install and use sway, but toolbox / podman seems to have broken.

You may want to compare the output of:
systemctl --user status

from the working configuration in gdm to your sway session.

1 Like

Somewhat embarrassingly, I decided to load the default sway config and it fixed the issue. So something is wrong with my setup in ~/.config/sway/config. When I figure out what it is, I will update this post (unless it’s even more embarrassing :joy:).

Edit: found this at the top of my config:

exec dbus-daemon --session --address=unix:path=$XDG_RUNTIME_DIR/bus

Removal fixed it :man_facepalming:. Thanks for all the help everyone! :heart:

1 Like