Online accounts - Nextcloud connexion problems

Hello everybody,

I have a hard time connecting to my Nextcloud from a fresh install of Fedora 36. I’m using the pretty straight forward Online Accounts manager, and this is the result:


I’ve looked up for this “Code: 8 - unexpected response from server” but didn’t find a lot.

In order to see if it was a server issue, I installed the Nextcloud Desktop application and it connected without any problem. It could still be server related, but if it is, I’m lost.

I found this thread: codeblock/w8upd-doorcgi
Trying to follow what was said, I thought it might be the sssd.service.

#sudo systemctl status sssd.service

sssd.service - System Security Services Daemon
     Loaded: loaded (/usr/lib/systemd/system/sssd.service; enabled; vendor pres>
     Active: inactive (dead)
  Condition: start condition failed at Thu 2022-06-30 19:50:16 CEST; 5s ago
             ├─ ConditionPathExists=|/etc/sssd/sssd.conf was not met
             └─ ConditionDirectoryNotEmpty=|/etc/sssd/conf.d was not met

And I figured the (dead) part of it could be a good clue. But I don’t know what the sssd.service is, what it does and if this has anything to do with my problem.
On the other hand, I tried connecting with my very fresh Fedora account, and it worked.

This is what I was able to do on my own, which is not much. And now I can only ask for help.

You might have to check the server name where you log in.
As server I just did put the URL without https:// and this worked.

Thank you @ilikelinux for you response but that doesn’t work.

The sssd service should be unrelated here. This should be your Nextcloud login credentials, not your local user. Also, if you have multi-factor authentication enabled in your Nextcloud, you’ll need to generate an app password in Nextcloud and use it in the password field for Nextcloud in Gnome.

No 2FA in the Nextcloud.
And I already tried generating app password in Nextcloud with no success.
Also, no problem login from the Nextcloud Desktop application, it’s just the Online Accounts in Gnome Settings that is unable to login.