GOA - Gnome Online Accounts - Nextcloud

since Fedora 37 I cannot add my Nextcloud account anymore. Even trying it in the live environment it is not possible. Using other distros it is no problem.
The window always show “Connecting…” but the moving circle stucks immediately:

With fedora you are always a step ahead. So you also will face problems first here :wink:

Which next cloud provider are you using? If you installed it on your own, is it up to date?
Are you behind a corporate firewall/proxy?

I use https://woelkli.com/en (free, from home) and it works fine with F37, Gnome.

I have 2 Nextcloud instances that I host by myself.
One is at version 25.0.3, the other at 25.0.4.
I tried different internet connections, no proxy or firewall issue. The Distros that worked have been on the same net.
It already ran with both instances but some weeks ago I moved one instance to the same physical machine as the other runs on.
Connection/decision is made via their DNS names.
I cannot say if these problem exists since that migration or even earlier.

I am also having this issue with Fedora 37 and Gnome Online Accounts with my own instance of Next Cloud 25.0.4 running on a snap deployment.

After filling out the server and log in information, my screen also gets stuck at “Connecting…” and then I get a “Settings is not responding” window in which I can Force Quit or Wait. Choosing to Wait never seems to allow the Setting window to resolve the issue, so I have to just Force Quit. The Force Quite option does not close the Settings window, just the Nextcloud Account dialogue box.

I have tried this on a brand new deployment of Fedora 37 and existing Fedora 37 install. I deleted my Nextcloud account on my existing Fedora 37 install (which I no issue setting up months ago) and I can no longer sign in now. Also, I have tried both the IP address and domain name of the Nextcloud server and neither made a difference.

It seems as though some update along the way has broken Nextcloud with GOA and I am surprised that this is the only place that I could find someone reporting this issue. I hope this is resolved soon.

1 Like

I had the same issue and it was related in my case to intermediate certificated not present on the nextcloud server.
It would be goo if their where feedback and not be stuck in connecting.
Hope this helps.

thanks for the hint.
I just found other posts and the problem has been solved by not using
in NGINX config.

After NGINX restart I could connect without any failure…

See also: 3.45.2: freeze of the app when adding nextcloud account (#213) · Issues · GNOME / gnome-online-accounts · GitLab
I did not test that workaround myself yet.