Onboard.x86_64 core dumped

Whenever I run this command I get this on Fedora 39:

$ dnf list onboard
Last metadata expiration check: 0:01:48 ago on Tue 06 Feb 2024 11:35:21 AM UTC.
Installed Packages
onboard.x86_64                          1.4.1-34.fc39                           @fedora
$ onboard
11:37:32.564 WARNING Config: mousetweaks GSettings schema not found, mousetweaks integration disabled.
11:37:32.912 WARNING Indicator: Failed to setup D-Bus match rule, no left-click Activate() for AppIndicator: org.freedesktop.DBus.Error.MatchRuleInvalid: Invalid match rule
Segmentation fault (core dumped)

OS: Fedora Linux 39 (Thirty Nine) x86_64


Hello @pseco ,
It appears onboard is still having difficulty reaching parity on Wayland like it enjoys with X. In the near term, you could log into your session of Gnome as an Xorg session insted of a Wayland session, and this should solve your crash/lack of usability issue. When you login at the prompt, the :gear: Icon is down lower right once you select the user, if you click on that icon you can select Gnome on Xorg, then login as normal. This setting will remain in effect until you select otherwise and survive reboot/shutdown and restart, etc… I’m also adding the accessability tag to this topic since it is about just that.


from onboard-1.4.1-34.fc39 | Build Info | koji : […] (Xorg only)

from Overview - rpms/onboard - src.fedoraproject.org : Package is currently unmaintained. Orphaned for: Unmaintained upstream – Crashes with Python 3.12 and does not compile against Python 3.13

So that package is retired, and will be removed from future Fedora Linux releases. Sounds like it’s time to look for an alternative…

1 Like

Added accessibility

There is onboardosk, but currently not in the repos. That was the original onboard forked to be rewritten in c++ entirely without python in the mix, but is still not at par on Wayland. @mattdm who is heading up the accessibility team within the project? I think this is a “hot burner” issue for them , or should be. Also to add to the state of this in the conversation here, I link the Gnome Wayland current state on this … Accessibility/Wayland - GNOME Wiki!

I have got a similar problem using onboard on a tablet PC (onboard being by far the best in its category). Fedora Mate 39. It worked very well with F38.

21:37:00.056 WARNING HardwareSensorTracker: Failed to connect to acpid, SW_TABLET_MODE detection disabled. (‘/var/run/acpid.socket’: [Errno 2] Aucun fichier ou dossier de ce type)

(onboard:13841): Gdk-CRITICAL **: 21:37:02.058: gdk_window_thaw_toplevel_updates: assertion ‘window->update_and_descendants_freeze_count > 0’ failed

When I move the pointer above the Onboard button, it crashes every time

Erreur de segmentation (core dumped)

(segmentation fault)

Detail :

$ loginctl show-session 1 -p Type

I also used the onscreen keyboard on LightDM to open my session. Since the F39 upgrade, this keyboard shows when asked but crashes and disappear when I press any key.

1 Like