[Crash] Launching ANY application logs me out of my Fedora 40 Workstation

After I boot up my Fedora and login to my user account, I cannot launch any app (including the settings or gnome-calculator, etc) because it hangs for a while and then logs me out.

I can enable wifi just fine. Notifications come in just fine. So that means my gnome-panel and desktop work just fine.

I used CTRL+ALT+F2 to switch to tty2

What have I tried?
I have tried the commands:

  1. sudo dnf distro-sync --allowerasing --best
  2. sudo dnf distro-sync --refresh
  3. sudo dnf update
    Output: Nothing to do.

I have also tried creating new user account via the tty2:

  1. # adduser

I have also tried reinstalling an older kernel:

  1. sudo dnf install kernel-6.8.5-301.fc40.x86_64
    Same issue.

What is the last thing I remember doing when it was working ok?

  1. I did sudo dnf update via terminal instead of using gnome-software
  2. I removed old kernels as I had more than 3 kernels and also because current kernels were working just fine.


  1. A log taken right after the system crashjournalctl --user -n 200 https://paste.centos.org/view/raw/71e3acea

Please help me fix my laptop.

One of the logs in journalctl says: Dependency failed for org.gnome.SettingsDaemon.XSettings.service - GNOME XSettings service. Could that be an issue?

Removed gnome-software

Could you provide more logs? Also without “–user” option?

Do you want to know from the point where the problem started? Or just from last boot?

Is 30,000 lines without --user worth posting here?

Hi there. What you’re describing looks similar to this issue.

Does the below answer solve your problem too?


Yes! dnf downgrade mesa-* has solved my problem. I didn’t even have to reboot. Thank you so much for this!


Added mesa