New kernels broke display, help required!

Heyyy, in the recent kernel updates I found a breaking issue which makes my desktop unusable, it’s glitching all over, until now I was able to use older kernels but it gets really annoying to always select the older working kernel when I reboot,

Here’s an image what it shows, I can log in and use it, as other stuff works, just the display somehow shows everything very badly, I can navigate through fedora, but can’t read text as much, and can’t see the right part of the screen, this type of glitching starts after the boot manager starts loading the kernels, at starts it shows the manufacturer’s logo which is then already broken and glitching
I didn’t had this issue with older kernels, last kernel which worked for me was 6.6.8, any newer (when I updated 4 kernels or so) did this glitching
Could someone pls help me though this?

Okey specific hardware details: Asus ROG zephyrus g15 ga502iv
Latest fedora version, all updated,
Stuff I also do on machine: kvm virtualization with GPU passthrough(worked fine)

Can you ssh into that PC from another to run commands?

If so please install inxi, sudo dnf install inxi, and post the output of inxi -Gxx please. Post by copy-n-pasting the text, no screen shots. You can use the </> button to post as pre-formatted text. That looks…

like this

Hii yeah

inxi -Gxx
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Max-Q] vendor: ASUSTeK
    driver: vfio-pci v: N/A arch: Turing pcie: speed: 8 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:1f12
  Device-2: AMD Renoir [Radeon RX Vega 6 ] vendor: ASUSTeK driver: amdgpu
    v: kernel arch: GCN-5 pcie: speed: 16 GT/s lanes: 16 ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 06:00.0 chip-ID: 1002:1636 temp: 34.0 C
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell v: 44.9 driver: X: loaded: amdgpu,modesetting
    unloaded: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: Sharp LQ156M1JW16 res: 1920x1080 dpi: 142
    diag: 395mm (15.5")
  API: OpenGL v: 4.6 vendor: amd mesa v: 23.1.9 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM 16.0.6 DRM
    3.57 6.7.7-100.fc38.x86_64) device-ID: 1002:1636 display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.

I’m writing this from mobile and I don’t really have that button so I hope this works

The </> button on snall screen devices can be found in the :gear: menu.

You could try installing the rpmfusion nvidia drivers for yout GPU.
See Howto/NVIDIA - RPM Fusion
FYI - Pay attention to the info on secure boot.

I edited it for you. NP

1 Like

Yeah I tried installing them, but those drivers were already installed, rebooted and still doesn’t work, note: I don’t have secure boot enabled,
Also my display isn’t directly connected to my Nvidia GPU so maybe that’s not the problem?
My laptop has Optimus so it uses integrated graphics by default