Kernel 6.9.4 is unbootable on my system


After updating today from kernel 6.8.11 to 6.9.4, my system now cannot boot (stuck on motherboard manufacturer logo forever).

I believe it might be because I manually updated via dnf from the terminal, then after a few hours I shut down my computer and was presented with an automatic update from GNOME Software (which I accepted). Maybe those two updates “intercepted” …or something? I don’t know, I have no clue how to read logs. Nevermind, this is wrong.

Here is the output of inxi -Fzxx:

  Kernel: 6.8.11-300.fc40.x86_64 arch: x86_64 bits: 64
    compiler: gcc v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell
    dm: GDM Distro: Fedora Linux 40 (Workstation Edition)
  Type: Desktop Mobo: ASRock model: B450M Pro4-F
    serial: <superuser required> UEFI: American Megatrends v: P1.60
    date: 08/01/2019
  Info: 6-core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP
    arch: Zen+ rev: 2 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1779 high: 3200 min/max: 1550/3200
    boost: enabled cores: 1: 1550 2: 1550 3: 1550 4: 1550 5: 2937
    6: 1449 7: 1372 8: 1550 9: 1550 10: 1550 11: 3200 12: 1550
    bogomips: 76647
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a
    ssse3 svm
  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: ASUSTeK
    driver: nvidia v: 550.90.07 arch: Pascal pcie: speed: 8 GT/s
    lanes: 4 ports: active: none off: HDMI-A-1 empty: DP-1
    bus-ID: 07:00.0 chip-ID: 10de:1d01
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa alternate: nv
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled
    model: HP E243m res: 1920x1080 dpi: 93 diag: 604mm (23.8")
  API: OpenGL v: 4.6.0 vendor: nvidia v: 550.90.07 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GT 1030/PCIe/SSE2
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib device: 0
    type: discrete-gpu driver: N/A device-ID: 10de:1d01 device: 1
    type: cpu driver: N/A device-ID: 10005:0000
  API: EGL Message: EGL data requires eglinfo. Check
  Device-1: NVIDIA GP108 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 4
    bus-ID: 07:00.1 chip-ID: 10de:0fb8
  Device-2: AMD Family 17h HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 09:00.3 chip-ID: 1022:1457
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-1.4:4 chip-ID: 03f0:2147
  API: ALSA v: k6.8.11-300.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit
    Ethernet vendor: ASRock driver: r8169 v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
    chip-ID: 10ec:8168
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: cz-prg state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 1-10:3
    chip-ID: 2357:0604
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter>
    bt-v: 5.1 lmp-v: 10
  Local Storage: total: 1.39 TiB used: 640.27 GiB (45.1%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SKC3000S1024G
    size: 953.87 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter>
    temp: 23.9 C
  ID-2: /dev/sda vendor: Samsung model: PSSD T7 size: 465.76 GiB
    type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 serial: <filter>
  ID-1: / size: 952.27 GiB used: 381.15 GiB (40.0%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-a459eefc-2e20-4ee7-af38-2183ccef3f5c
  ID-2: /boot size: 973.4 MiB used: 387.1 MiB (39.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 952.27 GiB used: 381.15 GiB (40.0%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-a459eefc-2e20-4ee7-af38-2183ccef3f5c
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 33.0 C mobo: 30.0 C gpu: nvidia
    temp: 35 C
  Fan Speeds (rpm): fan-1: 0 fan-2: 1025 fan-3: 0 fan-4: 0
    fan-5: 0 gpu: nvidia fan: 40%
  Power: 12v: N/A 5v: N/A 3.3v: 3.38 vbat: 3.25
  Memory: total: 16 GiB available: 15.53 GiB used: 2.63 GiB (16.9%)
  Processes: 451 Power: uptime: 2m wakeups: 0 Init: systemd
    v: 255 target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 130 Compilers: gcc: 14.1.1
    Shell: fish v: 3.7.0 running-in: kgx inxi: 3.3.34

Currently I’m using the older kernel from the boot menu that shows up after an unsuccessful boot.

Can you provide journalctl -xe would be nice to see if anything hit the logs.

What happens if you hit the ESC key? Do you see boot messages?

1 Like

Nothing happens, the system is completely unresponsive.

I just did journalctl -xe > log.txt (I’m not sure if that’s the right way to do this, I’m kind of tech illiterate, I apologize.) but the output is too large and the forums will not let me post a reply. I checked everything in it, nothing seemed relevant though.

It is most likely something to do with the pinned thread at the top of the forum regarding SELinux breaking, everyone is getting different symptoms for the same problem of their system not booting. I haven’t tried it yet but someone on another thread stated turning off Secure Boot fixed their issue (which doesn’t sound like it would be related but IDK).

Is there a way to make kernel 6.8.11 the default in the meantime? Because every time I turn on the computer, it tries to boot 6.9.4


sudo grubby --info=ALL

Mark down what “index” number of the kernel you want to boot (will probably be 1 if you just updated, 0 will be current kernel).

Then issue:

sudo grubby --set-default-index=<NUMBER>

then reboot.


I booted a previous kernel, then (as root, or using sudo):
rpm -qa | grep kernel
dnf remove kernel6.9.4

I ran into the same issue this morning after upgrading to 6.9.4 from 6.8.11.

The post at Reddit - Dive into anything was what helped me.

It seems something changed with the interaction between the nvidia driver and the 6.9.4 kernel.

The suggestion to remove initcall_blacklist=simpledrm_platform_driver_init from the boot arguments is what worked.

1 Like

Removed audio, bluetooth, flatpak, pipewire, server, wireplumber

This fixed it, thank you <3

Even graphical LUKS password prompt works now, which stopped working a few updates ago.