Asus zephyrus laptop integrated display glitches

Hi.I have an Asus laptop with amd cpu and igpu a nvidia gpu (2060MQ). I tried to play minecraft modpack using polymc launcher (this is probably irrelevant). It froze my laptop and after hard reset the internal display started to glitch (only on fedora, uefi or dualbooted windows 10 is uneffected). So I tried updating the system to 39 guessing that it could somehow fix it. It didn’t. Then I tried using older kernel which works. Then I tried reinstalling nvidia drivers but it didn’t work (it still glitches even if I reboot without them installed to text mode). Then I reinstalled the effected kernels and still didn’t worked. I am getting clueless.
My suspicion is that there is a problem with the igpu drivers. But couldn’t find how to deal with that.

Not working kernel is 6.7.4 and working is 6.5.8

glxinfo | grep -e OpenGL.vendor -e OpenGL.renderer
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon Graphics (radeonsi, renoir, LLVM 17.0.6, DRM 3.57, 6.7.4-200.fc39.x86_64)