Missing icons in kinoite

@Siosm I’ll leave you the terminal message to see if you can solve this problem

Can you give us the output of rpm-ostree status?
Have you tried cleaning up and rebuilding icon caches?
Have you tried creating a new user with an empty configuration?

In the future, can you try copy/pasting the text here instead of posting images? This would help as the text from those can not be searched nor copied easily.

Ok

How do I rebuild the icon cache?

Update, I created new user normally but still still in the same

● ostree://kinoite:fedora/34/x86_64/kinoite
Version: Kinoite 34.20210319.0 (2021-03-19T16:03:22Z)
Commit: 5820dfbf8c6de268965e1d2c2da1d6ec9939bdac858e69217abb2eda8be3a40a
GPGSignature: Valid signature by C8D83B6AE4B8685A7290545FDB27818F78688F83

ostree://fedora:fedora/34/x86_64/silverblue
Version: 34.20210323.n.0 (2021-03-23T08:14:53Z)
Commit: da03457b0eb2bdc4541a43f986b7d47bfc91da6cce743635a6aa7aa24a008af3
GPGSignature: Valid signature by 8C5BA6990BDB26E19F2A1A801161AE6945719A39
[t@fedora ~]$ firefox
restorecon: SELinux: Could not get canonical path for /var/home/t/.mozilla/firefox/* restorecon: No such file or directory.

systemsettings5

kf.service.services: KServiceTypeTrader: serviceType “SystemSettingsCategory” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KServiceTypeTrader: serviceType “SystemSettingsExternalApp” not found
Failed to find desktop file for “systemsettings”
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/SubCategoryPage.qml:157:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/SubCategoryPage.qml:147:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo() { … }
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
kf.service.services: KServiceTypeTrader: serviceType “QImageIOPlugins” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KServiceTypeTrader: serviceType “KCModule” not found
kf.service.services: KMimeTypeTrader: couldn’t find service type “KParts/ReadOnlyPart”
Please ensure that the .desktop file for it is installed; then run kbuildsycoca5.
QWidget::paintEngine: Should no longer be called
QPainter::begin: Paint device returned engine == 0, type: 1
QPainter::translate: Painter not active
QPainter::setClipRect: Painter not active
QPainter::hasClipping: Painter not active
QPainter::setPen: Painter not active
QPainter::setBrush: Painter not active
QPainter::drawRects: Painter not active
kf.service.services: KMimeTypeTrader: couldn’t find service type “KParts/ReadOnlyPart”
Please ensure that the .desktop file for it is installed; then run kbuildsycoca5.
kf.service.services: KApplicationTrader: mimeType “text/html” not found

Can you try:

If you create a new user and login using that user you have the same issue?
Did you make any other changes in the system configuration?

I did not change anything, was reinstall fedora silverblue 34,make rebase for kinoite and the problem was already

Even after that the problem still persists

I’ll try making a fresh install to see if I can reproduce the issue but I’ve been unable so far and given the image based properties of rpm-ostree systems such as Kinoite / Silverblue, I can only speculate about an issue with hardware support on your system. Do you also have this issue on the classic Fedora KDE Spin LiveCD?

I’ve never tried it, I’ll try

But the curious part is, why only happens with the plasma kde and the other interfaces does not?

Kde plasma spin works perfectly on live CD, I will install and update to see if there is any problem

I just installed the spin kde and all good

Would it be possible to create a rahwide kinoite ISO for me to try or will it still take a long time?

Informe de que me rebase a los núcleos os e instalado sddm y plasma-desktop
Saw see if the error activates while I use the minimal plasma kde, but my first impression is, some packet is in conflict

I’ve just completed a fresh installation from Silverblue and switch to Kinoite and I don’t have your issues. There is apparently something different on your system leading to this problem but I can not reproduce it.

For what it’s worth, I’m having the exact same issue with Kinoite 34, even after a wipe and a fresh install of Silverblue + rebasing, which (I think) rules out any problems caused by errant files in /home or /etc.

Desktop files seem to be completely broken, applications and system components that aren’t already Flatpak-based won’t show up in the menus, the System Settings program is completely empty and spits out the same errors that omlet1241 noted in this post and all of the attempts at a solution in the above posts fail to produce results.

I’ve rolled back to regular Silverblue for now, but being able to use Kinoite at some point would be ideal. If there’s any more information I can provide for you, I’m happy to do so, since rebasing to Kinoite again is a relatively quick process.

Thanks for the report.

Have you tried rebuilding icon cache with kbuildsycoca5, either as user or root?

Are you using a custom locale? (i.e. non-english?). That’s the only thing that I have not tested yet and could differ from my installation. We’ve had localization issues in the past that I missed as I’m running in English.

I tried kbuildsycoca5 already, forgot to mention that. It spat out a bunch of “Service type not found” errors related to mimetypes and didn’t do anything to rectify the situation.

I think you may be on to something with the locale, though. While I use English on my system, it’s actually GB and not US. When I get some time later I could try rebasing and switching locales to see if that makes any kind of difference.

Update: I did the rebase and I swapped my locale to en_US with localectl and also deleted all the plasma-related locale settings that I could find in my home folder, but the problems remain the same.

Update 2: Forgot to mention earlier, but I used the regular Fedora 34 KDE spin recently (prior to my decision to switch to Silverblue/Kinoite) and it works perfectly, and the same spin has worked perfectly on my computer in the past, so I doubt it’s hardware-related, if that helps.

Update 3: Another user has reported having the same issues over in the general Kinoite thread.

Just to add, since the forum won’t let me edit my original post any further, I suspect something might be going wrong with the Kinoite build’s reaction to the way Silverblue sets up /usr as read-only and defaults to using /var as the root directory for many previously-root (in standard Fedora) subdirectories. It’s just a guess, though; I have no real evidence to back it up other than my current lay understanding of how Silverblue is structured. I did dig around and noticed that every application that Kinoite complains about “not having a valid desktop file” is still in fact present in /usr/share/applications.

I hope this makes some kind of sense and points to some kind of solution.