MacBook Pro Drivers

Hello everyone.

I have a Late 2012 Retina MacBook Pro 13 inch (MacBookPro10,2), fedora works great, however it doesn’t recognize my computer’s WiFi network adapter or microphone.

Those are the only problems I found. How can I download the necessary drivers?

I am not a programmer nor do I have advanced knowledge with the Terminal, I just wish I could download the drivers and install them manually.

I appreciate your help.

Support for older WiFI and audio devices is up to some user with time and expertise and willing to update an existing legacy driver to the current kernel.

Has wifi and microphone worked with a previous linux kernel?

I currently use an iMac late 2012.

Cheap USB WiFI and sound dongles that are supported by linux are helpful while waiting for the legacy driver to arrive or because installing legacy drivers “taints” the kernel which limits
your ability to get help with other bugs.

Wifi on this system has worked in the past using akmod-wl from rpmfusion-nonfree but I’m using a wired network at present.

vailable Packages
Name         : akmod-wl
Version      :
Release      : 46.fc38
Architecture : x86_64
Size         : 5.5 M
Source       : wl-kmod-
Repository   : rpmfusion-nonfree
Summary      : Akmod package for wl kernel module(s)
URL          :
License      : Redistributable, no modification permitted
Description  : This package provides the akmod package for the wl kernel modules.

You may be able learn more about available drivers using the Linux Hardware Database, but I only see macbook Pro 10,1 entries.

Thanks for your answer, the WiFi adapter works with Ubuntu 22.04, so I think it’s just a proprietary driver issue, but the microphone doesn’t work at all in linux.

I don’t know if it worked with earlier versions of fedora.

Most likely the mac is using a broadcom chipset for wifi. That can be seen using lspci.

If so then installing broadcom-wl from the rpmfusion repo may fix the problem.

The mic is a different, though similar, issue.

You will need akmod-wl & broadcom-wl. First, share mobile data via USB cable, use USB-to-LAN adapter or USB WiFi dongle to connect to Internet. Then you will have to enable RPMFussion free and non-free. Then install akmod-wland broadcom-wl using dnf. Reboot and WiFi should be working.

I just tried akmod-wl & broadcom-wl on an iMac 14,2. I have used them previously, but they were not installed on the current F38 system. I installed them and wifi shows up in settings with correct visible networks and passwords. Ethernet is active.

$ ip ad | grep wlp3s0
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state DORMANT group default qlen 1000

In journalctl there was:

Jun 07 13:44:28 fedora NetworkManager[1043]: <info>  [1686156268.9238] audit: op="connection-activate" uuid="db40d963-0d5e-4927-b81c-7248919c332a" name="X" pid=3927 uid=1000 result="fail" reason="Connection ' X' is not available on device wlp3s0 because profile is not compatible with device (mismatching interface name)"

In settings I clicked on “Forget Connection”, was prompted for the wifi password, and now ip ad gives:

: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether c8:e0:eb:44:d7:41 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp3s0
       valid_lft 259183sec preferred_lft 259183sec
    inet6 fe80::1734:4ae3:4cd8:1045/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

Thanks for your reply, I’ll keep checking.

Thanks for the reply.

I am not an advanced user with the terminal, how could I activate the necessary repositories? In the documentation I see that other repositories are activated that are not of interest to me, I don’t know if this affects the performance of the system or something similar.

Do you know if it is possible to only activate the necessary repositories for the WiFi and the microphone?

Thanks for your answer.

I’m still going through the documentation.

Well, I provided you the link to the instruction on how to enable RPMFusion, here it goes again - RPMFussion, I don’t know what to add more here. After you enable both free and nonfree repositories, you should update your system and reboot before continuing. The command to update (respond ‘yes’ to installation prompts, unless you disagree :wink: ):

sudo dnf update

After the reboot you will have to install both akmod-wl & broadcom-wl with this command:

sudo dnf install akmod-wl broadcom-wl

Reboot, it will take a bit longer that usual as drivers will be built and installed behind the scenes. Wait for login screen to appear, login and check if the option to join WiFi appeared.

Thank you very much for your help!

The WiFi works perfectly, but the microphone still doesn’t work. It also does not recognize external headphones.

Is there a similar method for the microphone?

i didn’t see this model in the LHDB, so we don’t know which audio chip(s) are used. Maybe you are the very few to get linux going on this model. Please post the audio section output from inxi --audio (as text, so it can found with searches, examples below).

Audio on linux is often problematic, and my late 2012 iMac is no exception. I’m currently using the rpmfusion non-free nvidia drivers and Xorg. I have some USB dongles for wifi and audio for times when linux support fails. In this iMac system:

$ inxi --audio
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel
  Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel
  API: ALSA v: k6.3.5-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.71 status: active

The speakers and microphone work, but not the rear panel headphone jack. I use an ancient USB sound dongle (Griffin IMic Audio In/Out driver: snd-usb-audio type: USB) with headphones. The “iMic” microphone input also works.

I also have and ADS USB audio box with S/PDIF support:

  Device-3: Texas Instruments PCM2902 Audio Codec
    driver: hid-generic,snd-usb-audio,usbhid type: USB

This gives very low volume on the headset, nothing for mike input.

Edit: Looked in back of the audio gadgets drawer and found a Turtle Beach USB sound dongle from 2007:

 Device-3: C-Media CM102-A+/102S+ Audio Controller driver: snd-usb-audio
    type: USB

This “works for me” with headphones, and also supports S/PDIF (not tested).

No worries. I’m glad it helped.

Regarding the mic. One of quick checks and fixes is to check if all inputs are unmuted. One of the ways to do that - run alsamixer in the terminal and unmute inputs, if muted.

If there is a double M at the bottom of a bar - that input is muted. Select muted input, press m key to unmute it.

Do you know if your headphones are supported by current linux kernel ?

Apple systems of that vintage have standard 3.5 mm stereo headphone jacks. The Settings/Sound control on my iMac of the same vintage as Javier’s Macbook does change from speakers to headphones when the 3.5 mm plug is inserted, but I only get sound from the headphones when using an external USB sound device. Sound did work with previous Fedora Workstation versions.

Hello, I don’t know, but no microphone is recognized, neither when connecting it nor the internal one.

When running ALSAMIXER, I get a result like the one you show in the image, but it doesn’t allow me to make changes with the M key. For the outputs yes, but not for the capture.