New to Linux, no Wi-Fi on v39 install on 2019 MBP, trying to find BCM4364 driver

Hi, hopefully a simple question. I have installed F39 workstation on a 2019 MBP but have no Wi-Fi access. I looked up how to solve this and ran lspci | grep -i network to discover I have a Broadcom 4364 driver but haven’t been able to figure out next steps.

I assume I need to download this BCM4364 driver and install it somewhere but I don’t know where to get it and I don’t know how to get internet access on this computer. If I connected to the internet with a USB internet adapter, wouldn’t I run into the same problem with Fedora not having the driver for that adapter? This seems like a circular problem.

Thanks for any help. I’m looking forward to hopefully using Fedora.

1 Like

Added workstation

The broadcom-wl package is available from the rpmfusion-nonfree repo.
That package has a dependency of akmod-wl. and will also require at least the kernel-devel and akmods packages as well. I don’t know what else may be required, but many keep a wifi dongle that is supported native on fedora (intel or similar) so they can connect to the internet using that dongle while getting the drivers needed for certain wifi hardware using proprietary drivers such as the broadcom.

The rpmfusion repos have info to enable them at

Once the repo is enabled then it is easy to use dnf to install the needed packages with
sudo dnf install broadcom-wl That will pull in all the necessary dependencies as long as you have internet connectivity.

Another possibility would be to use another machine that has internet access to download all the required packages to a usb device then use that device to transfer the files to the MBP and install from that device.

This link shows how that may be done.

1 Like

As someone new to Fedora, which I have installed on an older MacBook, I ran into the same issue and solved it as described above.

I didn’t have a WiFi dongle around, so my solution for giving the system temporary internet access was to plug my iPhone into the MacBook and trust it, which would provide internet via the phone. It is documented that this should work with Android phones too.


Added macbook

Thanks for the help. I accessed the internet via an ethernet cable, enabled both free and nonfree RPM fusion repositories, and ran sudo dnf install broadcom-wl and downloaded a lot of drivers. I still have no Wi-Fi after several restarts. Is there another step after that?

Thanks for the help. I’m doing essentially that. Was there another step you had to do after running sudo dnf install broadcom-wl?

Besides restarting the system, no other steps needed in my case. However, at one of the previous installations I had issues when I tried to install broadcom-wl before running the proposed updates. I.e. first let the system perform all the updates, only afterwords install rpmfusion repos and broadcom-wl.

One clear indicator that wifi was detected, was the Wi-Fi entry in the Settings app’s menu. Before that, the menu entry was missing.

Screenshot from 2024-03-27 22-04-57

One additional note that may be critical.

I do not know if an MBP laptop uses secure boot, but if secure boot is enabled then those drivers will not load.
You can use mokutil --sb-state to see if secure boot may be enabled, and if it is then you would need to disable that before the drivers can be loaded.

Good idea, thank you. I ran that command and received the message “SecureBoot disabled” so I don’t think that’s it.

What is the result of lsmod | grep wl after doing a reboot?
Have you run sudo dnf upgrade --refresh?

sudo dnf upgrade --refresh says “Nothing to do.”

after several reboots, lsmod | grep wl says

wl 6512640 0
cfg80211 1335296 1 wl

Now that you can see the wl module is loaded, what is shown with inxi -Nxx?
What is seen when opening the settings panel to configure the wifi?
What is shown with ip address?
What is shown with lspci | grep -iA4 network?

inxi -Nxx gives


Device-1: Broadcom BCM4364 802.11ac Wireless Network Adapter vendor: Apple
driver: N/A pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 14e4:4464

Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
rev: 3.2 speed: 5 Gb/s lanes: 1 bus-ID: 4-2.1.3:4 chip-ID: 0bda:8153

and lspci | grep -iA4 network gives

05:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4364 802.11ac Wireless Network Adapter (rev 04)

06:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)

07:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)

07:01.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)

07:02.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)

Since others have already given you a lot of great troubleshooting strategies, I’m going to pipe in an suggest that, at this point, it might be instructive to run a sudo journalctl -b 0 and do a forward search in the pager for “wireless” or “wl” or even “BCM4364” to see if you can additional clues on what’s happening with your wireless device.

Good luck!

Hey there, I had the exact same problem as you. Trying to get Linux Fedora v39 on my 2019 MBP 15" (with T2 chip and BCM4364 Wi-Fi card).

After installing this patched kernel specifically for T2 Macs (fixes driver issues for keyboard, mouse, touchbar, ambient keyboard lighting, etc.), I was left without a driver for Wi-Fi. I, too, went all the way down the broadcom-wl rabbit hole to no avail.

I finally found this similar post by someone with a similar problem and the given solution worked for me. Turns out you just need to install the missing firmware which has been extracted by someone and uploaded to Github. I hope this solution works for you as well.

Note: If this solution does not work for you try fresh installing Fedora and then executing the given steps. It only worked for me once I had fresh installed Fedora one more time, probably due to some dependencies between the packages that I had already downloaded (to try to solve this problem) that I wasn’t aware of.


Hi there, I was successful with installing fedora following the instructions from the site here:
I’m writing from an MBP 16" (2019), 2.3GHz i9, 32GB RAM, AMD Pro 550M 8GB, 1TB.
Most things work except for a few minor issues.
I haven’t had time to deal with it yet, but I’m going to write later.
Check out the tutorials for Fedora, they are detailed and I have been successful following them.

1 Like

Thank you, the T2 Linux Fedora iso and installation guide worked for me. Only issue was that I couldn’t download updates via the GUI but sudo dnf upgrade --refresh solved it via the terminal.


I’m not able to edit my previous comment so I’ll note here that it was specifically the sharpenedblade iso that worked for me, not the mikeeq iso