Look no X11 ! Running Gnome desktop without X11 on Fedora Silverblue 33

I discovered today that Chrome 87 can be run natively in Wayland so I thought it time to try to ditch X11 completely or at least configure mutter in gsettings so that XWayland is only running on demand.

I have fractional scaling enabled already so not wanting to remove that I ran the following:

gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’, ‘autostart-xwayland’]”

So XWayland no longer auto-starts at login and it only runs when I run an application that cannot run natively in Wayland.

The only impact I noticed with this change is the daemon for Dropbox wouldn’t run so I had to create a service using systemd (see below). On another machine of mine that runs Silverblue 32 I noticed that flatpaks that need XWayland wouldn’t run either but this is not an issue in Silverblue 33 thankfully.

So now I am XWayland free! Finally! :blush:

To run the Dropbox daemon as a service create the file dropbox@.service in /etc/systemd/system/ using the following command:

sudo nano /etc/systemd/system/dropbox@.service

Edit the file to contain the following:

[Unit]
Description=Dropbox as a service
After=local-fs.target network.target

[Service]
Type=simple
ExecStart=/usr/bin/env “home/%i/.dropbox-dist/dropboxd”
Restart=on-failure
RestartSec=1
User=%i

[Install]
WantedBy=multi-user.target

Then run the following command:

sudo systemctl enable dropbox@$(whoami)

And reboot.
Here are some screenshots of my X11 free system!

4 Likes