State of Chrome/-ium 87 with Wayland

Arch users report that regular Chrome dev (from version 87) can be run in Wayland with this command: google-chrome-unstable --enable-features=UseOzonePlatform --ozone-platform=wayland. I tried installing Chrome dev 87 rpm with rpm-ostree, but I have to disable GPU acceleration with a command line flag to make it run at all.

Here’s the error when I try to run without disabling the gpu:

[ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.

Rendering without GPU works well, but it’s obviously less than ideal. But it’s on Wayland, at least. Here’s the command I’m using: google-chrome-unstable --enable-features=UseOzonePlatform --ozone-platform=wayland --disable-gpu.

I haven’t seen any comments like this on AUR or the Arch forums. Could the RPM be missing some dependency to make Wayland work?

Also, I haven’t tried it on Fedora Workstation, so it could be possibly be a Silverblue issue?

2 Likes

Thanks so much for this post. Interesting news. I am running Fedora 32 Silverblue and I have tried the command:

google-chrome-unstable --enable-features=UseOzonePlatform --ozone-platform=wayland

And it runs fine for me. Looking glass shows that Chrome Dev is running natively in Wayland (not using XWayland). See attached screenshot.

Well done to everyone at Igalia who helped to make this happen!

2 Likes

Interesting that it works for you. On my computer it just doesn’t start at all. Wondering if it could be hardware-related? Although it would be weird, considering I’m on a Lenovo Yoga 720 with Intel graphics.

Also, the InitializeSandbox() error I posted above is pointless. The same error is there on regular Chrome 85 (and Chromium) as well, only there it’s starting and running well despite the error. So it’s not a sign of a showstopping bug after all. The problem must be something else. :thinking:

1 Like

For some reason I didn’t know that the Chrome repo in yum.repos.d with a baseurl with stable in it also contained the unstable version, so I had installed it with the rpm file so rpm-ostree status showed it as local package. Uninstalling this and using the regular repo version instead seems to work, although they’re both Google-provided rpms, so I have no idea why this would make a difference except for updates later. Oh, well, it works now!

I want Wayland to be good in general, but the main reason I care about this is fractional scaling at 150%. On a 165-DPI laptop screen, everything is too small on zoom level 100, and text scaling is ugly and hacky. (200 is obviously out of the question.) Very happy about this! Now if the Electron-based flatpaks follow suit soon, that would really expand the range of usable applications for me with Wayland. I’ve swapped applications I like (VS Code for a combination of Neovim and Gnome Builder and Mark Text for Apostrophe) to avoid blurry text, but I like some of those apps, so I hope they’ll switch to Ozone soon.

EDIT: I know it’s early days still, but I’ve seen on Github that the Electron people are aware of the fact that it works in Chromium now. But does that mean that Electron Flatpaks will use Wayland automatically when the flathub base-app for Electron applications is updated? Probably way too early to tell yet.

2 Likes