Login broken on Fedora magazine due to version upgrade


The login to Fedora magazine is broken since a few hours. I was pinged at 1h in the night in my time zone, and I wasn’t in a state of consciouness high enough to answer, so I look at it this morning.

After 1h of debugging, I found that the problem come from that change:
discussed on that ticket:

This break the OpenID auth who relied on the fact we do not need to enter login/password.

We have 2 WP plugins for the authentication.

One plugin that hide the login element of the form and autosubmit the form (written by @puiterwijk ). That’s a custom made plugin for Fedora, basically 4 or 5 lines of Javascript.

And the other one is a regular OpenID plugin, who is not dead, but not moving much (as you can see I was the one who fixed it for php 8, and not much happened since).

Since the 1st plugin hide part of the form, it was also hiding the error message about “this field need to be filled”. Once I removed that plugin and tested manually, I was able to see the issue (as before, it was just not clear why anything broke, no error message anywhere, so I fiddled around).

The fix should be easy, one of the 2 plugin should modify the DOM to remove the required attribute on both element.

The cleaner way is to do that on the OpenID plugin. The fastest way is to do that on the custom Fedora one, because that’s already what the plugin is doing, changing the DOM with jquery.

The main problem is that I am not sure where it live these days. I am right now trying to write a fix in production because people need to connect easily (as you can connect if you modify the HTML, but that’s not really easy to), but someone need to commit on the canonical location to not have it lost.

Also, while debugging (because, it sound easy once I give the solution), I had to fiddle with plugins, and so I disabled Jetpack (and others, 1 by 1, by order of last update before noticing that wordpress too had been updated). Turn out that to re-enable Jetpack, it requires some information I do not have. (to be fair, it showed a popup about how I would be losing all those features, but I dismissed it as some weird almost-dark pattern that appear all the time in the wordpress ecosystem. The popup didn’t say “if you disable, you can’t reenable”).

So whoever set it up need to take a look once it is fixed.

So the fix is adding:



document.getElementById("loginform").insertAdjacentHTML("beforebegin", "<p>You are being redirected, please wait.</p>");

(or anywhere, as long as that’s in the wpOnload() function).

I can still see the Jetpak but there is a broken connection to WP.com that requires credentials I don’t have to re-enable it, which I assume is the account login credentials for the site. Maybe @bcotton or @mattdm or @pfrields may know how to resolve it.

The hosting is provided by Red Hat’s OSPO, so I think @jflory7 can connect with the right people to get support. (@misc, maybe?)

You’re correct @misc was whom Idealt with in the past.

So, just to make sure I understand correctly, we are waiting on @jflory7 to connect someone from Red Hat OSPO to look at my request ?

LOL sorry I was posting while distracted and did not even notice that this is the context. Misc, if you can’t fix this, I don’t know who can. :slight_smile:

I found out that the same is happening on https://communityblog.fedoraproject.org/ as well. It’s stuck on redirection.

ok, I fixed it (I was out for the weekend and Friday, sorry).

And does this solution also solve the problem with the “Like” button on the articles?

Unlikely, I just touched to a small plugin streamlining the login process.

Got it! Thanks for taking the time to fix this.

Has anyone looked into the Jetpak part of this issue? If you try to look at the statistics you see a page indicating there is a missing connection.


I updated WP and connected jetpack. Try it out now please @rlengland .

Bingo! Thank you @jakfrost

You’re welcome! Apparently it’s mine now (Fedora Magazine Blog).

:smirk: You touched it last. :upside_down_face:
Thank you, again.