Can't login to community blog


I’m trying to add new post to Fedora Community blog and can’t log in. It’s just stuck on You are being redirected, please wait. page. Tried it in Firefox and Brave Browser with same result. I don’t see any error in communication everything ends up with 200, but I’m not getting redirected.

Me too, just trying now and it’s hanging at please wait being redirected. It doesn’t seem to even be trying to use OpenID to login, just redirecting indefinitely.

See: Login broken on Fedora magazine due to version upgrade

I think it’s the same thing, even though this is another different instance at the same provider.

1 Like

There’s a crappy workaround for now:

  • Click Register
  • In the Register using an OpenID: field, enter <YourFedoraID>
  • Click Register
  • Enter your credentials as normal

I fixed the plugin (same hotfix indeed).


I’m currently getting 500 when trying to log in:

I only see this in the console:

POST 500

So that’s a new error:

PHP Fatal error: Uncaught Error: Call to undefined function PublishPress\WordpressVersionNotices\Module\TopNotice\get_current_screen() in /nas/content/live/fedoracom/wp-content/plugins/capability-manager-enhanced/lib/vendor/publishpress/wordpress-version-notices/src/Module/TopNotice/Module.php:107
Stack trace:
#0 /nas/content/live/fedoracom/wp-content/plugins/capability-manager-enhanced/lib/vendor/publishpress/wordpress-version-notices/src/Module/TopNotice/Module.php(139): PublishPress\WordpressVersionNotices\Module\TopNotice\Module->isValidScreen()
#1 /nas/content/live/fedoracom/wp-includes/class-wp-hook.php(310): PublishPress\WordpressVersionNotices\Module\TopNotice\Module->adminHeadAddStyle('')
#2 /nas/content/live/fedoracom/wp-includes/class-wp-hook.php(334): WP_Hook->apply_filters(NULL, Array)
#3 /nas/content/live/fedoracom/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
#4 /nas/content/live/fedoracom/wp-content/plugins/openid/common.php(764): do_action('admin_head')
#5 /nas/content/live/fedoracom/wp-content/plugins/openid/common.php(746): openid_page('\n\t<noscript><p>...', 'OpenID Authenti...')
#6 /nas/content/live/fedoracom/wp-content/plugins/openid/consumer.php(59): openid_repost('https://id.fedo...', Array)
#7 /nas/content/live/fedoracom/wp-content/plugins/openid/consumer.php(179): openid_redirect(Object(Auth_OpenID_AuthRequest), 'https://communi...', 'https://communi...')
#8 /nas/content/live/fedoracom/wp-content/plugins/openid/login.php(27): openid_start_login('https://id.fedo...', 'login', 'https://communi...')
#9 /nas/content/live/fedoracom/wp-includes/class-wp-hook.php(312): openid_authenticate(NULL)
#10 /nas/content/live/fedoracom/wp-includes/plugin.php(205): WP_Hook->apply_filters(NULL, Array)
#11 /nas/content/live/fedoracom/wp-includes/pluggable.php(618): apply_filters('authenticate', NULL, '', '')
#12 /nas/content/live/fedoracom/wp-includes/user.php(106): wp_authenticate('', '')
#13 /nas/content/live/fedoracom/wp-login.php(1241): wp_signon(Array, true)
#14 {main}
 thrown in /nas/content/live/fedoracom/wp-content/plugins/capability-manager-enhanced/lib/vendor/publishpress/wordpress-version-notices/src/Module/TopNotice/Module.php on line 107

Likely a update of this plugin. No bugtracker, and it seems no one complained yet at the support forum. The error come from a unupdated vendored php component, and while looking at it, it seems to mix GPL v2 code and GPL v3+, which is a big nope, but I will have RH Legal verify that on Monday.

I can disable the plugin as a fix, but I am not sure what was the intended use case, especially since I think the regular user system is sufficient.

Does anyone know why it was installed, and if it can be safely removed ?

As no one seems to know, and since @jflory7 needed to edit a blog post there, I just disabled the plugin, and it worked for him and me.

Since people can connect, please tell in this thread if anything changed for you (eg, having more access, or less access that usual).

I doubt I will reenable the plugin, but if there is a need, it is important to make sure it is met (or that I explain why you really do not need it)

I also opened the ticket wrt the license a few hours ago, no answer yet.

Thanks for fixing that. I didn’t noticed any change for me.