Livestream on Firefox at first not displaying control buttons

I installed libavcodec-freeworld some months ago and it worked perfectly. Since codec updates (possibly libavcodec-freeworld) were automatically installed a few weeks ago as far as I remember, on Firefox on one website that provides several livestreams, when I click on the ‘Play’ button, the livestream is being played with audio and video but this symbol (red concentric circles, coffee cup belongs to livestream)
grafik
is being displayed which is flickering and which doesn’t disappear. The control buttons like timeline, volume and full screen are not being displayed only the ‘Picture in Picture’ button.

When I click on another livestream on this website and afterwards click on the original one again, the symbol disappears and all control buttons are being shown.

It seems that anything has hung up.

EDIT: This only takes place on one of the websites with livestreams that I go to.

What do I need to do so that the symbol is not displayed and the control buttons are shown directly?

Can you provide the site address?

My guess is the Web page has something layered on top of the actual video, like an advertisement.

Das Erste im Livestream (Livestreams of the german public television ‘ARD’)

I am typing this from Debian 12 and Firefox ESR.
You are right, I see the same behavior on Fedora 39 with the last Firefox release.

I also tried Chromium on Debian and it works as expected, much faster than FF I must say.

I don’t think it depends on codecs or drivers, more likely the video player embedded in the Web page has some issues with any version of Firefox. It seems the video in itself is correctly played once it starts.

Until somebody else comes with a better solution, I guess you can do the trick of playing another video and then back to the first one or you may use Chromium.

Edit: It looks like VAAPI is disabled by default in Chromium for linux.

So it works without the problems on Chromium?

Yes it does.

Like I wrote above, consider Chromium does not use VAAPI on linux (I think some flags must be set upon compiling plus some commands on opening) and I am not sure about Wayland (if you are interested, that can be enabled by chrome://flags looking for “ozone” and forcing “wayland”).

Anyway it works.

As it works without the problems on Chromium, do you think that it is a browser problem or a problem of the video player embedded in the Web page?

I use Firefox and that is the first time I saw such a problem.
So my guess is there is something in the player embedded in the Web page that doesn’t like Firefox.

If you really care of it you should report the problem to the site owners because it is them who are in the better position to understand and fix the issue.

Either them or Mozilla.
Some time ago there was a way to report broken sites to Mozilla but I don’t know if it is still the case.
We are back to the years when Internet Explorer was “the browser” or even “the Internet”, nowadays I guess Web sites are tested against Chromium and all its derivatives.
Even Microsoft doesn’t support or doesn’t fully support Firefox with its services.

Anyway, like I said, it is the same on Debian with the ESR and even the Nightly version of FF, it is not related to Fedora.

1 Like