Fedora 36: Cant play Twitch Livestrems in Firefox 102.0 Flatpak


first i want to say im relatively new to linux and even newer to fedora… i think im quiet a noob so dont be too hard to me :sweat_smile:

when i try to play a twitch livestrem in firefox im getting this Error:
Your browser encountered an error while decoding the video. (Error #3000)

when i look in the console i see this error:
Player stopping playback - error Decode:4 (ErrorInvalidData code 3 - NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<59>::InitDecoder(): Couldn’t open avcodec)

i have installed the rpm fusion repository and already installed alot of varietys of the different ffmpeg versions in dnfdragore.
i also installed vlc.
i also tried different firefox profiles (also default) so its not a setting i changed for hardening.
i also searched for avcodec in dnfdragora and installed them.

nothing of that worked, i hope someone can help and thanks in advance!

Welcome to ask.:fedora:edora @rolofogo13

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

I think, but someone should correct me, that if you use the Flatpak version, you can install whatever codec you want on the system, but they will not be used by flatpak version of Firefox since it uses the ones bundled in the flatpak itself (or by using a runtime extension [1]). So, probably, the “issue” lives in the flatpak package.

Well. Which package are you using? [2]
If it is the Fedora Flatpak one, it is likely that some codecs are not included (due to licences and patent issues). On the other hand, Mozilla Flatpak (installed from Flathub) is supposed to include various codecs, and as far as I understand, Twitch should work.

  1. Available Runtimes — Flatpak documentation ↩︎

  2. for instance, open the terminal and issue this command flatpak list | grep Firefox ↩︎


thanks for the quick reply! here is the output:

  Kernel: 5.18.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.2
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: Z97-K v: Rev X.0x serial: <superuser required>
    UEFI: American Megatrends v: 2902 date: 03/31/2016
  Info: quad core model: Intel Core i7-4790K bits: 64 type: MT MCP
    arch: Haswell rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 3071 high: 4003 min/max: 800/4400 cores: 1: 2099
    2: 1985 3: 1199 4: 3286 5: 4000 6: 4000 7: 3999 8: 4003 bogomips: 63968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Gigabyte driver: nvidia
    v: 510.68.02 arch: Maxwell bus-ID: 01:00.0
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: gpu: nvidia,nvidia-nvswitch resolution:
    1: 1920x1080~60Hz 2: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 980/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
  Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: NVIDIA GM204 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-3: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series]
    driver: snd_hda_intel v: kernel bus-ID: 06:00.0
  Sound Server-1: ALSA v: k5.18.7-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK AM1I-A driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 957.12 GiB used: 42.25 GiB (4.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB
    size: 465.76 GiB temp: 37.9 C
  ID-2: /dev/sda vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB
  ID-3: /dev/sdb type: USB vendor: Kingston model: DT 101 G2
    size: 14.42 GiB
  ID-1: / size: 475.35 GiB used: 40.25 GiB (8.5%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 973.4 MiB used: 200.7 MiB (20.6%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 475.35 GiB used: 40.25 GiB (8.5%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 632 Uptime: 3m Memory: 31.2 GiB used: 2.81 GiB (9.0%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 14
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

tanks for the reply!

i installed firefox using the pre installed “app store” and in the top right i chose

Fedora Linux (Flatpak)
URL: registry.fedoraproject.org
Installation: system
Branch: stable

when i issue your command i get this output:

Firefox	org.mozilla.Firefox	100.0	stable	fedora	system
1 Like

Yep. This is the point. As I’ve briefly exposed in the previous post.

I think that you have two options.

  • Install the flatpak version of Firefox from Flathub: https://flathub.org/apps/details/org.mozilla.firefox

  • Install Firefox from the Fedora Linux RPM repository. In addition you have to install the third party RPM Fusion repository and all the multimedia codecs. But as far as I can understand from your first post, you already installed such things.

1 Like

Alright thank you very much!
i just installed the Flathub version and it works.
Can i somehow implement the Flathub versions in the “Appstore” or do i always have to use their website?

1 Like

You can install the Flathub repository

thanks again! you have helped me alot.