Live image doesn't boot

Will not boot live image gets stuck at this line and will not go any further.
“A start job is running for Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling”
Anyone know a work around?

Boot hangs waiting for LVM partition to be mounted” – Maybe related.

Thanks but that looks like a already installed system.
I am trying to boot the usb and it stops that at that line
any other ideal

See if this makes sense
I was trying to install Fedora on HP 14-dk0002dx
31and 32 stop here and will not boot the live image
However 30 does boot the live Image but it can not find the nvme drive and other distributions that boot the live image can’t find the nvme drive ether
So is that why 31 and 32 hang at the LVM2 line because it can not find the nvme drive? suggest to choose UEFI in the BIOS. There is some other things to try there… but the guy there have give up and installed an other drive.

i have no idea of why, what and how of this. But i remember reading something similar and someone suggested to make sure his Live USB was dual Bootable (UEFI & BIOS), and as far as i remember it worked for him. To enable it > Download Rufus>after select the iso file when making bootable USB press Alt+E to initiate Dual Boot for USB. I dont if it will help but give it a shot maybe if you haven’t tried it already!

Thanks for the info
But I have tried every possible thing I can think of, secure boot - off, fast startup - off, legacy boot - on, I think it’s call tpm the thing that remembers your password - off.
With legacy boot off I was able to boot either with UEFI or BIOS still no go.
From what I have researched OEM are using raid instead of ahci for their windows installs, why raid when there is only one disc I don’t know
And what makes it worse is you can’t change it in the bios because they have removed the option, no where to be found
Can’t believe they are locking down laptops now

I got the similar issue, but system really boots… and it takes 3+ minutes.
The issue with live image and with upgraded system (F31 → F32). Guess there’s a problem with udev device initialization (tooooo loooong).
There’s similar bug on bugzilla, so confirm your issue there too.

I have one computer that takes awhile to boot
But with this laptop it stops at that line
I even left it while I watched a movie so almost 2 hours and still stuck
I really think it’s because it can’t find any drives because it is in raid mode
It boots just fine on my system76 laptop

1 Like

@sprintcowboy I am having the same issue on my asus (N56VZ) laptop. Did you also try booting FC31 installation media? This working working fine for me, so I am guessing it’s an regression in FC32. What are your observations?.

@rickvanderzwet I have to go back to F30 but once booted to the live USB still can not see the NVME drive.
I have learned since that AHCI is for SATA drives not NVME drives so I assume that is why the setting is not in the UEFI

Managed to get mine system installed again.

I have created a modified F32 live CD with updated systemd, following the suggestion. Instruction for creating the updated live CD here. If you like a link to a pre-generated (x86_64) image to test please let me now.

@rickvanderzwet Hi Rick! Yes, can you send me a link to the pre-generated (x86_64) modified CD image that you created? I tried the GIT instructions (easy enough), but I’m experiencing an exception. I think one of the sites the GIT post depended on is gone. Do you still have your F32 modified live CD? Thank you in advance.

Out of curiosity what kind of error do you get when generating the image?

I have shared my generated (x86_64) generated image here:

Hi Rick. Thank you for providing me with this. :blush: Sorry to be consuming your bandwidth as I download it right now. Give me a couple of days and I’ll reproduce my problem and paste it here. Reason: I’m currently rebuilding my system as you read this. I’ve upgraded Fedora many times (and across machines) without issue, but going to Fedora-32 caused me issues on two now (which others have run into, too). I’ll report back soon. Thank you again!

@rickvanderzwet Actually, I get the same booting issue as with the regular (unmodified) LiveCD:

A start job is running for Monitoring of LVM2 Mirrors, snapshots, etc. using dmeventd or progress polling ( min / no limit).

RedHat has basically wrecked upgrades, installs, LiveCDs, etc., etc., etc. since Fedora 30, 31, 32. Every remedy / alternative that one turns to is freaking broken (fresh install, upgrade, etc). Ridiculous.

Thank you for the modification, though (not your fault). It’s hanging for me (never gets past the above).

Thanks for trying and sorry to hear, was hoping you were also affected by the efi variables + systemd bug which the modified CD was hoping to circumvent.

Looks like there is also something odd going on while trying to poll for NVME drives, looking through the bugzilla database on nvme related issues reveals a few open issues. How-ever no clue if this would help you any further.

If possible you could try to remove/disable the NVMe drive and find out whether this is the actual root cause, how-ever I am not sure whether this knowledge will help you with the actual installing of fedora.

Debugging pre-boot issues are slightly difficult, since you are lacking at the cool debugging tools.

1 Like

I replaced the nvme with a nvme samsung evo pro
Live image booted with no problem and Fedora 32 installed without issue
So I assume it was encrypted somehow although I could not find it
Or the nvme was not compatible with linux
What ever it was its working fine now with the new nvme ssd

1 Like