How to boot to nvme and install grub to external drive?

I have one SSD and two NVME.

My old motherboard does not detect the NVME to boot it.

I tried to install the system and the boot in the NVME, but it was not detected by CLOVER (GitHub - CloverHackyColor/CloverBootloader: Bootloader for macOS, Windows and Linux in UEFI and in legacy mode).

I tried to install the system in the NVME and boot on USB Stick, but the GRUB accuses the “Unkown Filesystem”.

I tried to open the GRUB via the command line and when typing “blkid” or “ls -l”, NVME is not detected.

How can I install the boot on an external disk but load the system inside the NVME ?

1 Like

I was having similar issue.
To solve this I had to change the uefi setting.
Find sata type and change it from intel raid something something to 'acipe…:ess type of word?

1 Like

I’ve tried to install Fedora using UEFI and LEGACY.
Both gets same problem :frowning:

Any good soul may help me, please?

Did you try to find out that in the bios (the comment from @rijan )?

Please give feedback!

Is your system able to see the nvme drives as-is?

If it does then the suggested fix in bios may work.
Also, if the bios has the intel Rapid Storage Technology (RST) feature enabled then that should be disabled.
Finally, if Secure Boot is enabled then that should be disabled as well.

Those 3 items are the prevalent causes for fedora to not see or access a drive on most systems.

I never used IDE or RAID before.
I ever kept it on AHCI.

1 Like

Yes, I can see the NVMe with the file manager, or simple using “blkid” or “fdisk -l”

But, I can NOT see the NVMe in the bios, I have an Intel DX58SO2 and it don’t support booting into NVMe :frowning:

I’ve tried using UEFI and legacy too.

I’ve tried to install the /boot to another disk detected by the BIOS for booting, but it fails too.

Probably, I will have to keep Fedora on the SSD and then use the NVMe just simple as storage.

Just thinking loud. Creating the MBR for legacy mode on SDD. Keep about 10mb fee space before everything. Making a small partition and mountpoint it as /boot and the rest for /home (also on ssd). Now if you can see your NVMe you could make a mount point for / on it.

Maybe preparing the whole thing with gparted and while installing choose manual installation and not automatic.

This sounds like an older bios. Maybe an update to the bios would make it able to support nvme.? Has happened before!

@computersavvy old hardware seams not have updates anymore.