F31 live usb doesn't work on LG Gram 14' (but manjaro live usb yes)

Hi all,
recently I have bought a LG Gram 14’ and the idea is to install F31 in dual boot with windows.
Then I:

  1. complete the windows initialisation process for the first start;
  2. enter in the bios setup
  3. disabled the secure boot and deleted the passwords, or whatever has been created by windows in the initialisation process
  4. put the USB in 1st position for boot, and
  5. reboot.
  6. a bios window appeared asking to select a device good for boot
  7. the F31 live usb, created using Fedora Media Writer (as per the instruction here, was not good for boot.
    Then I:
  8. googled about boot problem with LG Gram and linux
  9. founded something in the Manjaro world
  10. tried with a Manjaro live usb and booted correctly to a live session.
  11. just for the record, I tried to burn F31 in the usb stick using the same step done with the Manjaro ISO but the result didn’t change.
  12. Tried to start the boot in the old pc and there the F31 live usb worked.


  1. could it be a problem with the UEFI part of the live usb?
  2. anything I can try to install F31?


I don’t know the cause of this problem, but a suggestion might be useful to try fedora iso with last update .(google translate)

The official Fedora iso files on getfedora.org remains constant because the Fedora life cycle is relatively short , and it is the files that was tested before being approved .

maybe your device needs a iso file with a higher version of Kernel not available in official Fedora iso file ,or something like that.

Another thing to check can be:

The USB option, If you are installing in UEFI be sure you select the option of the USB with PREFIX “UEFI”

So you should in a system compatible with Legacy and UEFI at least see 2 different entries to the same USB in the boot options.

USB fedora (Install run in mode BIOS/Legacy)
UEFI:USB fedora (Install in mode UEFI)


You can also try burn the .iso with Rufus selecting GPT and UEFI maybe it help (not idea)

Good luck.

that kind of choice is available only if I put the pen drive in the old pc, there I see two entries, one with UEFI and another without.
I tried to use the following command to create the live usb:
livecd-iso-to-disk --format --reset-mbr --efi
but at the boot I see 6 white text row declaring something not found or whatever, it stays a couple of seconds, very hard to read, then Manjaro boot options appear.

I will try with rufus next time, but should not be so difficult.

Did you check if you are running your windows in BIOS or UEFI mode?

you can check it from windows —> https://www.easyuefi.com/resource/check-windows-is-booted-in-uefi-mode.html

How is your partionstable in windows GPT or MBR ?

You can check iit from windows → https://www.howtogeek.com/245610/how-to-check-if-a-disk-uses-gpt-or-mbr-and-how-to-convert-between-the-two/

When you know that your windows install does have select the same options if you are going to use rufus.

Your bios should indicate you if this is running in LEGACY (Bios) or UEFI too. you can check it.

I will leave to you another post where another guy had a similar issue but it was because he needed install in BIOS mode and Fedora was not loading the live session. The post is important because will show you important information about BIOS/UEFI and about fedora. Check the post, sure will help you.



thank you for your time.

The already installed windows is on a GPT partition and the pc use the UEFI mode.
Of course to install manjaro I already disabled the secure boot and deleted the passphrase (or whatever was the name) created by Win during the first boot.

So I tried to create a F31 live usb using these information (UEFI/GPT) and rufus but the result doesn’t change: some lines declaring something not found and then the boot window created by Manjaro appears asking if I want to use manjaro or Windows.

For what I know, because Win has been installed in UEFI/GPT I cannot select the old bios mode, isn’t it?
So I need to install F31 in UEFI/GPT or loose the Win OS etc.?


Yes it is. like you say

Yes it could resume so, you will not be available to run WinOS.

I am not sure but it maybe is related with secure boot and fast boot.

1-Disable fast boot (if you didn’t yet) you can do trough windows and also via BIOS in some of them.

2- Can you provide some pictures of your bios with secure boot disable and model of your BIOS, maybe you did miss something —> https://www.reddit.com/r/archlinux/comments/7wch1n/problem_installing_arch_on_lg_gram/


Fastboot disabled.


1 Like

These are the white text I see for 2 seconds before the manjaro boot selection, unfortunately the quality is very poor because meantime the autofocus works the text disappears, anyway:

I checked the live usb and in that path I can see some files and one directory (fonts):
BOOT.conf BOOTIA32.EFI BOOTX64.EFI fonts grub.cfg grubia32.efi grubx64.efi mmia32.efi mmx64.efi


Thank you for the image/s now try it:

1- Enable UEFI Secure boot you already has it disabled —> change to Enable (you are trying start from un UEFI usb so it should be on)

2-Secure boot Option -->disable like it is right now

3-You did delete all signatures so this step you don’t need change, (I also did install default secure boot keys from my BIOS manufacture, but it doesn’t /should care from your secure boot options is disable but maybe is important if you want enable again in the future and have a fresh keys without rest of others installers).

I want believe than your problem is just you did disabale UEFI when it need is enable. (Don’t forget check the USB than you did burn before you began the installation,in this case it did run.
LIVE usb Fedora has a Test check run it to see the burning was ok before you do continue)

Edit1: Sorry maybe i am wrong in these option. Because you should have Uefi enable and these option in your bios is only to disable secure boot and not uefi. But i think still that it is related with your bios options or fast boot from windows did you disable fast boot.


The options related to UEFI and these related to Secure boot are in two different pages of the bios options.
UEFI is enabled (and must be, because Windows has been installed in UEFI so I cannot install F31 in the BIOS mode) but the Secure boot option is disabled.

  1. fast boot disabled (but now the OS selection is in charge of manjaro, so I don’t think fast boot can do anything until I select to boot windows)
  2. UEFI enabled
  3. Secure boot disabled.

I tried to enable secure boot but the only result is that to gain access to the bios I need to login the OS and select “open UEFI in the next start”, however the usb live shows always the same text.

I will try to boot an ubunto live usb and see if it works or not.

1 Like

From the UEFI menu boot screen, what did you see? Post a screen shot if possible.

In General, things to check:

  1. UEFI model enabled
  2. Secure Boot disabled
  3. USB Boot enabled (and for that particular USB port. Some motherboard cannot boot from USB3 port. Try with USB2 port if possible.)
  4. Goto UEFI boot menu. See if the UEFI Fedora and / or the USB Drive is listed. Try each one.

If all else fails, check if there is any Bios update from your mainboard. You can do that in Windows.