Fedora LiveUSBs wont boot

Greetings to all,

I’m helping a friend try and do a bit of forensics on a system crash they had about a month ago.

Oddly, I can’t seem any Fedora LiveUSB to even be recognised as bootable medium by this machine, or my own

I’ve tried a few different USBs, both F36 and F37 images (checksums all verified) and several flashing utilities (Fedora media writer, rufus, dd) with no luck. I thought at first it may be the laptops USB ports, bu when I sanity checked with my own desktop test rig (an ancient PBH-77M) and laptop (Dell XPS 9560), I saw exactly the same behaviour.

I can’t get any permutation or combination of images, usbs and flash tools to boot register as bootable in the BIOS on any machine I have access to, regardless of any UEFI/legacy settings I can think to change. The drives register, but selecting simply goes nowhere, as if trying to boot from an empty disk.

The same USBs, flashed with the same utilities, can boot an Ubuntu image on my hardware no problems. These also boot on the crashed laptop, but seem to hang/fail at the first splash screen (for other display related reasons, I’m fairly sure).

But in any case, it clearly seems to be an issue with the Fedora images. I personally installed F35 with the same methods not long ago, and dont recall needing to do anything too arcane? So I can only conclude something’s happened with recent Fedora images to make them problematic with certain (older?) hardware platforms. A short scan of reddit seems to indicate I’m not alone, either.

I’ve since pulled the SSD from the crashed machine and will recover data that way, but I was wondering if anyone else has seen this behaviour, and if there’s a known fix? I sure cant find it and don’t even know where to start troubleshooting.



We need to know exactly how the USB drives were written.

I commonly use fedora to create the flash drives with sudo dd if=Fedora-.......iso of=/dev/sdX bs=32M where the input file is the exact iso image being copied and the outout device is the flash drive as it is identified by the system.

Udev usually automatically mounts file systems when a usb device is attached.
One thing I have noticed is that if ANY of the partitions/filesystems on the usb device are mounted then dd usually tells me it completes but the written image fails. Thus I ALWAYS make certain that no file systems on the device are mounted before I issue the dd command.

I suspect that rufus may also have similar issues and I also always use the iso mode with rufus.

Like I said in the first post, I used Fedora Media Writer, Rufus, and dd (the very same command you give as an example, although I don’t specify block size.

I never encountered the problems you describe, and this method still works fine for Debian-based distro images.

Hence my stance that this is not a problem with how the drives are written, but what is being written itself (ie. the Fedora images)

You didn’t say if you verified the downloaded image.

$ sha256sum -c Fedora-Workstation-37-1.7-x86_64-CHECKSUM
Fedora-Workstation-Live-x86_64-37-1.7.iso: OK
sha256sum: WARNING: 17 lines are improperly formatted

Um…actually I very clearly did:

Recently, I’ve tried booting a lot of different usb media (including a fedora iso written by fedora media writer onto an 8GB usb stick) in a lot of different computers. I’ve had lots of combinations of image/computer that don’t work (including that fedora image in two computers) and zero clue why.

But I have one that worked in every computer:

I put ventoy on an 8GB usb stick and wrote the fedora iso as a file into the filesystem that installing ventoy sets up. That stick boots into ventoy on every computer (some bios’s see both partitions of that stick as bootable and you need to select partition 2 from the bios boot menu. Others correctly see the whole stick as just one boot choice).

Once Ventoy boots, it can boot into the fedora iso.

Can confirm that.
Using Fedora Media Writer and recent Fedora ISO, the USB doesn’t boot.
Flashing Debian image with Fedora Media Write on same USB, it boots right away. The same happened a while ago with older releases Fedora/Debian distros, so I can agree that it’s not USB or BIOS issue, but the image itself.