LibreOffice (Flatpak) crashes in Wayland

Hi All,

Yesterday i installed Fedora 35 the kde spin. All went well and worked fine, with up to now only one problem. That is Flatpak-LibreOffice crashes all the time. I changed from Wayland to x11. That helped and LibreOffice works fine now also.
What to do? Is this a bug in Wayland or LibreOffice. Can i stay on x11 and can i not use Wayland anymore? Is that a problem for me?

Kind Regards

1 Like

Kde plasma is not much stable in wayland it is experimental for kde and kde is trying to make it stable for wayland. There has been lots of stability work done in plasma 5.23 and in this one it is fairly usable. As of now fedora 35 ships kde 5.22 so it is safe to use x11 for now at least.

Yes. You can stay on X11. As @frankjunior points out, wayland is still considered experimental on KDE. Just my opinion, but Fedora made it the default much too soon. It still isn’t ready, even in plasma 5.23.

That being said, it is one of those things where we all have different hardware and use different software. If wayland works for you, great! If not, just use x11 until plasma support for wayland gets to a point where it works for you personally.

Another option, and one I use all the time, is to not use the flatpak but instead use the normal rpm version of LO. Since flatpaks tend to stay with a particular environment that may or may not match the OS there are sometimes problems like you see.

I would suspect that if you were to remove the flatpak version of LO and install the distro version instead all the issues would disappear.


The same problem as described in the topic.

I have two different machines, but they have the same Fedora Silverblue on them. On the machine, where X11 works, LibreOffice works fine, and on the other (where Wayland works) it does not. However, switching the second machine to X11 also did nothing. The difference was only how long the office worked - under Wayland it was active 30 seconds, in X11 1-1,5-4 minutes.

I would be very grateful for thoughts about why Libreoffice, working on a Fatpak, breaks down. As I have established, this is hardly the reason in Wayland.

I have this same problem in Wayland, but libreoffice is installed via dnf:

$ libreoffice ./any.ods                                                                                                                           
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()                                                                               
The Wayland connection broke. Did the Wayland compositor die?                                                                                     

A workaround is to run libreoffice with:

$ XDG_SESSION_TYPE=x11 libreoffice ./any.ods

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.12-200.fc35.x86_64 (64-bit)
Graphics Platform: Wayland

The issue appears to be libreoffice using wayland → fails while libreoffice using X → works.

However, since your system is NOT silverblue and the OP uses silverblue then your issue is different and you really should open a new topic for your problem.

Yesterday i tried Fedora 36 KDE spin again and the problem is still there.