Why does Zoom instantly crash on Wayland

I am on Fedora 38/KDE Plasma/Wayland and have tried the snap, flatpak, and official rpm versions of Zoom. They all crash immediately after attempting to login. I am able to launch a Zoom meeting from the browser that opens in the app, but if I try to login it will still crash.

It will be helpful if you provide some system information. Please post the results of inxi -Fzxx. The command collects a lot of data about the system and may be helpful in finding what exactly is wrong.

A crash can happen for a bunch of reasons, this hopefully point us in the right direction.

Have you verified this is wayland? Does zoom open properly when using xorg?

I use X and zoom installed as rpm works for me. Zoom 5.14.7 on Fedora 38 kernel 6.4.9.

Thanks, I’ll give this a try and see what pops up.

Yes, I have another Fedora install that works fine in X11. The only problem I have with that one is that it doesn’t remember any of my settings or keep me logged in, but the app is useable.

I tried both Flatpak and the RPM today in Plasma Wayland. Both crash on launch once logged in, although it seemed like the RPM made it one screen further before crashing. Flipped to X11 and it works totally fine. Tried turning hardware acceleration for it off, didn’t help. Launching it from the command line doesn’t yield any useful output. This is with an AMD 6800M GPU.

I’m going to keep troubleshooting and will follow up.

I seem to recall that there have been threads in the past about zoom failing on wayland but working on X11.

I launched zoom through the flatpak. It crashed when when I tried logging in as mentioned. I have an nvidia gpu, so I assume the GPU vendor is not relevant.

I tried tweaking the flatpak permissions through flatseal to see if i can get it to work. I turned off the “Wayland windowing system” option and it started to work without crashing. I got into a meeting but could not share my screen.

It might be worth it to test if this works and if there are any other drawbacks doing so. I don’t use Zoom much so its very possible that I missed many other issues with running Zoom like this.

It’s just weird that if I join a meeting from the browser, it launches from the app and works fine and only crashes when I try to login…Wayland doing Wayland things. We’ll have to see what Plasma 6 and QT6 can do for it.